Bug Hunting Session
Bug 92524 - FILESAVE from .doc to .docx - white highlight and white color fill added to paragraph style
Summary: FILESAVE from .doc to .docx - white highlight and white color fill added to p...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other All
: medium minor
Assignee: Justin L
URL:
Whiteboard: target:6.0.0
Keywords: filter:doc, filter:docx
: 107287 (view as bug list)
Depends on:
Blocks: DOCX-Paragraph DOCX-Styles
  Show dependency treegraph
 
Reported: 2015-07-03 13:36 UTC by Buovjaga
Modified: 2017-10-30 05:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Doc from Europass CV generator (68.50 KB, application/msword)
2015-07-03 13:36 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2015-07-03 13:36:38 UTC
Created attachment 117021 [details]
Doc from Europass CV generator

Spin-off from bug 92500.

Doc file is saved from https://europass.cedefop.europa.eu/pt/documents/curriculum-vitae

Saving it from LibO to .docx, the Ansioluettelo text in the header gets a white highlight background, obscuring the header image.

Odt saved from Europass does not exhibit this problem.

We do not know what engine Europass uses for the doc generation.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+ (x64)
Build ID: 8b788891796ff0571f779cdbe8ce809c35c42754
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-02_23:09:27
Locale: fi-FI (fi_FI)
Comment 1 MM 2015-07-03 20:15:06 UTC
Confirmed with v4.4.4.3 under windows 7 x64.
Confirmed with v5.0.0.2 under mint 17.1 x64.

Don't know if it has anything todo with that word 'Ansioluettelo'.
If you move it all the way down before saving, there's still a white line through the picture/frame when reopening.
Problem is also not there when saving to .doc again.
Comment 2 tommy27 2015-07-04 09:09:52 UTC
bug present in 4.1.0.4 as well (Win8.1x64)
Comment 3 Xisco Faulí 2016-04-28 10:56:13 UTC
This issue is still reproducible in

Version: 5.2.0.0.alpha1+
Build ID: e7f55f15ccd97bc92e1400bc5862171a621da3e2
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-04-27_00:29:05
Locale: es-ES (es_ES)

However, the white highlight isn't seen in window office 2010
Comment 4 Buovjaga 2016-10-13 05:47:38 UTC
Noting that it *also* gets white area fill.

I tried testing with an older version, 3.5, but it seems styles are not even imported.

Win 7 Pro 64-bit Version: 5.3.0.0.alpha0+
Build ID: e2f6c7f0d0cc14f851d7028ff846c5dc658a81c6
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-10-10_23:08:02
Locale: fi-FI (fi_FI); Calc: group
Comment 5 Buovjaga 2017-04-20 11:36:11 UTC
*** Bug 107287 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2017-10-30 05:17:49 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9b8a99a1886997f91535ed613e50b3691c716ea1

tdf#92524 ooxmlexport: recognize COL_AUTO for RES_BACKGROUND

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.