Bug Hunting Session
Bug 92550 - UI: Mouse movement up impaired by Formula Bar
Summary: UI: Mouse movement up impaired by Formula Bar
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 102306 106115 (view as bug list)
Depends on:
Blocks: Calc-Formula-Bar
  Show dependency treegraph
 
Reported: 2015-07-05 09:56 UTC by Emil the Detective
Modified: 2019-06-16 05:10 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emil the Detective 2015-07-05 09:56:08 UTC
1. Create/open a calc document.
2. Make sure the Formula Bar is visible.
3. Slowly move the mouse cursor up from the spreadsheet over the Formula Bar to the icons above the formula bar.
4. When the mouse cursor reaches the middle/top of the formula bar, it jumps down to the spreadsheet again.

Notes
- The mouse moves up just fine when moved *around* the Formula Bar (i.e. outside the LibreOffice window.)
- Moving the mouse quickly often allows it to jump over the Formula Bar.
- Hiding and re-showing the Formula Bar seems to cure the problem. I was able to reproduce the problem 100% with LibreOffice 4.3.7.2 on Mac OS X 10.0.4 before hiding and un-hiding the Formula Bar. Afterwards, the problem went away and I am having a hard time reproducing it.
Comment 1 Joel Madero 2015-07-05 19:50:56 UTC
To clarify - you can't reproduce it at all with a new calc document any longer? If so the best thing we can do is close this bug as WFM. Our volunteers time is really stretched thin and spending time trying to reproduce a bug that the original reporter cannot even reproduce is just not a wise use of time.

Marking as NEEDINFO - please let us know if you can reproduce the issue still with a new calc document then mark as UNCONFIRMED. Thanks!
Comment 2 Emil the Detective 2015-07-06 20:46:40 UTC
I can reproduce it, but it is no longer very visible, just a slight flicker while the mouse cursor travels upwards.

My best guess is that by hiding and unhiding the Formula Bar, some internal setting was reset to a sane value, making the problem almost invisible.

The original phenomenon was really bad behavior, but since there is a work-around, I think it is just a minor annoyance. Maybe this is simply something to document?
Comment 3 Alex Thurgood 2015-07-12 08:32:05 UTC
No repro on

Version: 5.1.0.0.alpha1+
Build ID: 9136f2344af88d524b6c10b6b2dfd6017bba60ec
Locale: fr-FR (fr.UTF-8)
Comment 4 Alex Thurgood 2015-07-12 08:37:56 UTC
@Emil : as you are the only person to apparently have suffered from this, and you now can't reproduce it, or at best, to an almost imperceptible extent, I am setting this to WFM.

The majority of users do not slowly move their mouse cursor from the spreadsheet through the formula editor to the toolbar above, and as we have tons more bugs that are reproducible and in need of attention on OSX, I would be inclined to let this one go.
Comment 5 Adolfo Jayme 2015-07-17 00:57:54 UTC
(In reply to Alex Thurgood from comment #4)
> […] and as we have tons more bugs that are reproducible and in need of
> attention on OSX, I would be inclined to let this one go.

That reasoning is dangerous. Just because you consider some bug unimportant should not be the lone reason to close a report. We do not revolve around one user’s wishes. LibreOffice is developed by volunteers who decide where to put their effort and spend their time.
Comment 6 Paul451 2017-02-11 10:46:40 UTC
I've just had the same weird glitch. Came across this report while looking for a fix. Hiding-then-unhiding the formula bar resolved it. 

Version 5.222. Under Win7. Works with any file, not just a newly created Calc workbook.

To repeat the bug:

(If you've changed the default bevahiour, make sure the formula entry field is in single line mode, not multi-line.)

On the Formula Bar, place the mouse pointer on any of the Wizard, Sum, or Function (=) buttons, move the mouse pointer down until the pointer icon changes from a normal arrow-pointer to the frame-drag double arrow.

Left-click while the mouse pointer is displaying the frame-drag icon, but the wizard, sum, or function button is still highlighted.

Now try to move the mouse pointer up. Flick, flick, flick.

To activate the bug, the button must trigger. If the mouse is on the border-area but too far below the button, clicking does nothing. Hence, the bug won't trigger on the formula entry field, the cell-name and drop-down, nor the Expand Formula Area button. Those have just enough separation between them and the border-area. And of course you can't trigger the bug when the formula entry field is in multi-line mode.

Therefore I suspect the bug is triggered by some overlap between the button-area mouse-detection and the border-area mouse-detection.
Comment 7 Buovjaga 2017-03-19 16:23:10 UTC
*** Bug 106115 has been marked as a duplicate of this bug. ***
Comment 8 Buovjaga 2017-03-19 16:23:35 UTC
*** Bug 102306 has been marked as a duplicate of this bug. ***
Comment 9 Buovjaga 2017-03-19 16:30:31 UTC
*** Bug 106115 has been marked as a duplicate of this bug. ***
Comment 10 JMM 2017-03-19 16:58:27 UTC
I've been able to reproduce this bug using Paul451's steps. Clicking below the input area where the double arrow to drag appears also fixes the problem.

5.2.5.1 (x64) under Windows 7.
Comment 11 Buovjaga 2017-03-19 17:29:33 UTC
Repro with steps from comment 6 in 3.6. Version 3.3 did not yet have the resize ability.

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 12 tmacalp 2017-04-11 16:38:33 UTC
One of my users runs into this bug all the time and is quite frustrated by it.  My workaround has been to manually resize the formula bar by dragging a spot that isn't over a button.  When it's resized back to its normal size, the behavior is fixed.

After a bit of experimentation, another workaround is to place the cursor over one of the buttons, hold left-click and then right click.

While I agree that this is easy to work around once you understand the behavior, it's quite frustrating and very easy to accidentally trigger.  On my system, the section that overlaps both a button click action and the resize action is 3px tall.  With the button itself only being ~20px tall, that's a good chunk.

The other elements in the formula bar appear to handle this behavior properly and override the resize action with their own.
Comment 13 Alex Austin 2017-07-17 17:12:39 UTC
I can confirm this bug, on Debian Jessie, with 4.3.3
Comment 14 QA Administrators 2018-07-18 02:38:57 UTC Comment hidden (obsolete)
Comment 15 mahfiaz 2018-07-24 12:00:13 UTC
I have seen this behaviour before (#102306), but I can not reproduce this on 6.0.3.2 anymore. I have switched to Linux Mint with Mate desktop, maybe this, maybe it really is fixed.

Please reopen this if it is still a problem with a recent version.
Comment 16 Buovjaga 2018-07-24 16:37:47 UTC
Hmm it is true that I cannot repro.

Version: 6.2.0.0.alpha0+ (x64)
Build ID: de6b0c6edce0b9237fa43d12e258bf5fa568f6a7
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-07-16_05:06:14
Locale: fi-FI (fi_FI); Calc: group threaded
Comment 17 john smith 2019-03-04 08:31:14 UTC Comment hidden (spam)
Comment 18 mmavovaforlists 2019-06-15 22:44:39 UTC
I can reproduce it on Debian:
https://youtu.be/HpTAPJVl7QU
Comment 19 Buovjaga 2019-06-16 05:10:52 UTC
(In reply to mmavovaforlists from comment #18)
> I can reproduce it on Debian:
> https://youtu.be/HpTAPJVl7QU

You are using 5.2.7.2.
Please rather try with a fresh version, preferably with 6.3 beta: https://libreoffice.soluzioniopen.com/