Bug 92638 - Formatting - Borders disappear when reloading an ods file.
Summary: Formatting - Borders disappear when reloading an ods file.
Status: RESOLVED DUPLICATE of bug 75260
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.4.3 release
Hardware: x86-64 (AMD64) Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-07-08 23:59 UTC by Bob
Modified: 2016-10-07 15:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bob 2015-07-08 23:59:58 UTC
This bug persists in version 4.4.4.3 as reported in bug Id 79260. This can be reproduced by the following steps:
1) Create a new spreadsheet.
2) Select a cell, then right click and select the format cell menu item.
3) Select the borders tab.
4) Select any one of the default line arrangements and click the Ok button.
   The borders are rendered as expected.
5) Save the file and close. The image in the collective view is as expected.
6) Open the spreadsheet. The borders have disappeared.
Comment 1 m.a.riosv 2015-07-09 08:58:35 UTC
Hi @Bob,

I can't reproduce with Win7x64
Version: 4.4.4.3 Build ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8

Please have you test if the cell format is there and not showed.

What you could try is resetting the user profile sometimes solves strange issues.
https://wiki.documentfoundation.org/UserProfile
Comment 2 Bob 2015-07-10 15:32:37 UTC
Resetting the profile folder as advise corrected this issue. Thank you for your quick and accurate response.
Comment 3 m.a.riosv 2015-07-10 16:29:41 UTC
Thanks for comment Bob.
Comment 4 Bob 2015-07-10 16:41:59 UTC
Although the problem appears to be resolved when using the default line style, as originally documented, it persists when using a different line style. This can be reproduced by the following steps.

1) Create a new spreadsheet.
2) Select a single cell, then right click and select the format cell menu item.
3) Select the borders tab.
4) Select a double horizontal line From Line Style and place it on one of the    cell's horizontal lines. Click the Ok button. The double line is rendered as expected.
5) Save the file and close. The image in the collective view is as expected.
6) Open the spreadsheet. The double horizontal line has disappeared.
Comment 5 m.a.riosv 2015-07-10 21:03:24 UTC
Good catch @Bob.

Reproducible.
Win7x64Ultimate
Version: 4.3.8.0.0+ Build ID: 2d13cf60ecdab83997c9cd7275c799ddd96617cd
Version: 4.4.5.1 Build ID: 1b6df295803ea040dab1b48b5424da8d78d94cf0
Version: 5.0.0.2 (x64) Build ID: a26d58f11b99b6aeddf7f7884effea188cc6e512
Version: 5.1.0.0.alpha1+ (x64) Build ID: 0251e61640b94094918406b33ee7b05564409feb
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-06_23:45:07

Last working.
Version: 4.2.8.0.0+ Build ID: 1fc1d0d7d38bb16832d0d78d78682ed2d5f8716f

Could be this bug with similar issue.
https://bugs.documentfoundation.org/show_bug.cgi?id=88743 (saving as xls)

Setup as hight and critical because is a problem with ods file format.
Comment 6 MM 2015-07-19 14:04:49 UTC
Looks a bit like bug 88827
Comment 7 V Stuart Foote 2015-07-19 17:57:34 UTC
A regression and is bibisected as in bug 88827, duplicate.

*** This bug has been marked as a duplicate of bug 88827 ***
Comment 8 Xisco Faulí 2016-10-07 15:35:30 UTC

*** This bug has been marked as a duplicate of bug 75260 ***