Bug 92663 - FILEOPEN: cannot open .csv files by clicking on a hyperlink in IE
Summary: FILEOPEN: cannot open .csv files by clicking on a hyperlink in IE
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: All Windows (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: preBibisect, regression
Depends on:
Blocks: CSV-Import
  Show dependency treegraph
 
Reported: 2015-07-09 16:47 UTC by Maxime de Roucy
Modified: 2021-02-26 12:04 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maxime de Roucy 2015-07-09 16:47:27 UTC
This bug is exactly the same as the #66232 but it appear on .csv.

The bug is still present in master~2015-07-09_00.11.56_LibreOfficeDev_5.1.0.0.alpha1_Win_x86.msi

To reproduce it :
* On windows 7, fresh install of LO (with WRITE_REGISTRY=1)
* right clic on a csv → Properties → Open With "Modify…" → select Calc (event if it is already selected) → OK → OK
This manipulation was made to set "HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.csv\UserChoice" Progid=soffice.StarrCalcDocument.6

* open Internet Explorer and try to download a csv, for example : http://sql.sh/ressources/sql-villes-france/villes_france.csv

* select "Open"

LO is launch in the background.
The only way to stop it is to kill it with taskmgr.
Comment 1 Clément Lassieur 2015-07-09 19:00:20 UTC
I can’t reproduce with version 3.5.7.2.

With version 3.6.0.4 and 3.6.1.2, LibreOffice crashes.

It behaves as Maxime described since 3.6.2.2.
Comment 2 Joel Madero 2015-07-11 22:36:55 UTC
Given the last comment I am doing the following:

Updating version to reflect first issue (the crash would be separate issue);
Setting to NEW (confirmed)

"regression" to keywords;

bibisectRequest - if someone wants to take a stab at bibisecting this which would help us figure out where things went wrong, feel free to come poke us in the QA chat :)

http://webchat.freenode.net/?channels=libreoffice-qa

Minor - slows down but does not prevent high quality work (requires one extra step to download it to your computer first);
Low - default
Comment 3 Clément Lassieur 2015-07-15 16:47:32 UTC
(In reply to Joel Madero from comment #2)

> bibisectRequest - if someone wants to take a stab at bibisecting this which
> would help us figure out where things went wrong, feel free to come poke us
> in the QA chat :)

I think it’s not bibisectable, because the only active repo is win32-5.0
and that doesn’t include 3.6.
Comment 4 Clément Lassieur 2015-10-21 10:02:57 UTC
Note that if you remove
HKEY_CLASSES_ROOT\soffice.StarCalcDocument.6\CLSID,
LibreOffice behaves normally. (I mean like in 3.5.7.2.)

The process tree is then:

explorer.exe
  iexplore.exe
    iexplore.exe
      scalc.exe
        soffice.exe
          soffice.bin

instead of

wininit.exe
  services.exe
    svchost.exe
      soffice.exe
        soffice.bin
Comment 5 Robinson Tryon (qubit) 2015-12-10 01:26:35 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2016-09-13 10:52:43 UTC
This regression was introduced before branch 4.4, thus it can't be bibisected with the current bibisect repositories. Changing keyword 'notBibisectable' to 'preBibisect'
Comment 7 fvroman 2017-06-26 12:08:07 UTC
Not reproductible with 5.2.6.2 / Win7 / IE11
Comment 8 QA Administrators 2018-07-21 02:39:50 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2020-07-21 03:47:26 UTC Comment hidden (obsolete)
Comment 10 Svatopluk Vít 2021-02-26 12:00:38 UTC
Not present in 7.1.1.1 (x64) / Win10 Pro 20H2 / IE11 20H2.

Looks like fixed.
Comment 11 Svatopluk Vít 2021-02-26 12:04:26 UTC
Version: 7.1.1.1 (x64) / LibreOffice Community
Build ID: 575c5867c4cc13d7ae78f9ce39a54a52ed38c769
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: cs-CZ (cs_CZ); UI: cs-CZ
Calc: threaded