Bug 92686 - FEATURE REQUEST: Better UI for keyboard bindings configuration (including two keybindings for the same action)
Summary: FEATURE REQUEST: Better UI for keyboard bindings configuration (including two...
Status: RESOLVED DUPLICATE of bug 52335
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-11 18:24 UTC by Jakub Narębski
Modified: 2018-01-11 09:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jakub Narębski 2015-07-11 18:24:36 UTC
Configuring keybindings in LibreOffice is major pain in the ass, especially on MS Windows, where Ctrl-Alt bindings are indistinguishable from AltGr (right Alt) bindings used for international keyboards (like Polish programmers keyboard). Notepad++ shows that it is possible to distinguish between Ctrl-Alt and AltGr, but LibreOffice currently cannot do that; this is also against Microsoft recommendations (some netbooks do not have right Alt, so they need to be able to use Ctrl-Alt emulation).

Scrolling through the list of possible keybindings is tedious, compared to MS Word / MS Office (and Atom editor) solution of just entering key we want to assign (the advantage is that you see if it is free or not at first glance). This is especially tedious if you want to have backup binding, i.e. two key bindings to the same action: 1) you scroll all the way down to the binding you want to use, 2) you select the action, 3) if there was keybinding, for some [censored] reason LibreOffice rewinds you to that keybinding, as if having it in list of binding would be not enough, 4) you scroll all the way down *again* to keybinding you want 5.) click Modify, 6.) see two keybindings for action.

Also, if you select for example Ctrl-Alt-Shift-N for "Normal" style, and have Polish programmers keyboard, what you would get is 'Ń'... and there is nothing in the keyboard configuration UI that even hints at this issue.

It would also be nice to have keybindings in human readable format (XML, JSON, INI, XKB, xmodmap,...), just compiled to binary internal format on loading.
Comment 1 Joel Madero 2015-07-11 20:35:17 UTC
UX needs to decide this one. Pushing to NEW and setting component to ux-advise.
Comment 2 Heiko Tietze 2015-07-12 14:51:38 UTC
Have you read this, Jakub? http://user-prompt.com/how-to-make-libreoffice-customization-usable/
Comment 3 Jakub Narębski 2015-07-12 15:20:33 UTC
(In reply to Heiko Tietze from comment #2)
> Have you read this, Jakub?
> http://user-prompt.com/how-to-make-libreoffice-customization-usable/

No I haven't. Thanks for pointing it. I especially like the fuzzy search idea for functions and for groups / menus.

There are however a few issues that this blog post doesn't touch.

1.) There is no information anywhere that you can press a key combination to go to it, to appropriate line in "Shortcut keys" - it should be in a label, or at least in a hint.

2.) It doesn't touch the current difficulty of assigning second key to an action.

3.) There is also an usability issue (that I forgot to mention) that clicking 'OK' instead of 'Modify' after selecting function looses all your work on the last shortcut. Perhaps better solution would be to click Modify first, then open a wizard to select a function...

4.) Ctrl-Alt vs AltGr issue, and inability to assign for example Ctrl-Alt-n or Ctrl-Alt-Shift-N to any function when using Polish keyboard with ń and Ń.
Comment 4 Cor Nouws 2015-07-12 18:49:54 UTC
(In reply to Jakub Narębski from comment #0)

> Scrolling through the list of possible keybindings is tedious, compared to
> MS Word / MS Office (and Atom editor) solution of just entering key we want
> to assign (the advantage is that you see if it is free or not at first
> glance). 

When the focus is in the list with keys, and you hit Ctrl+F, the focus immediately jumpes to that key, showing the info you are looking for..
Comment 5 Jakub Narębski 2015-07-12 19:00:18 UTC
(In reply to Cor Nouws from comment #4)
> (In reply to Jakub Narębski from comment #0)
> 
> > Scrolling through the list of possible keybindings is tedious, compared to
> > MS Word / MS Office (and Atom editor) solution of just entering key we want
> > to assign (the advantage is that you see if it is free or not at first
> > glance). 
> 
> When the focus is in the list with keys, and you hit Ctrl+F, the focus
> immediately jumps to that key, showing the info you are looking for..

What is lacking is small text above this list with e.g. "Press key combination you want to change", or something like that.
Comment 6 Cor Nouws 2015-07-12 20:00:54 UTC
(In reply to Jakub Narębski from comment #5)

> > When the focus is in the list with keys, and you hit Ctrl+F, the focus
> > immediately jumps to that key, showing the info you are looking for..
> 
> What is lacking is small text above this list with e.g. "Press key
> combination you want to change", or something like that.

That would indeed a better UI. Is it OK for you to make this issue reflect just that suggestion?
Comment 7 Jakub Narębski 2015-07-12 20:11:44 UTC
(In reply to Cor Nouws from comment #6)
> (In reply to Jakub Narębski from comment #5)
> 
> > > When the focus is in the list with keys, and you hit Ctrl+F, the focus
> > > immediately jumps to that key, showing the info you are looking for..
> > 
> > What is lacking is small text above this list with e.g. "Press key
> > combination you want to change", or something like that.
> 
> That would indeed a better UI. Is it OK for you to make this issue reflect
> just that suggestion?

I have created *this* issue because of annoying behavior wrt. adding duplicated keybinding to the same function. This is a separate issue, and I can raise a separate (and quick to fix) bug report.

There remains long term issue that needs a discussion about best UI for assigning keybindings (for keyboard configuration), for example whether to make it more similar to what MS Word 2007 does, or what Atom editor does.
Comment 8 Cor Nouws 2015-07-12 21:07:09 UTC
Hi Jakub,

(In reply to Jakub Narębski from comment #7)

> I have created *this* issue because of annoying behavior wrt. adding
> duplicated keybinding to the same function. This is a separate issue, and I
> can raise a separate (and quick to fix) bug report.

Yes please do.
Side note: applying two bindings for the same is easier when you first select the function, without bothering the keys list, and after that selecting the proper key by putting the focus in the list and pressing the desired key. But hard to tell that in the current UI without real help text, I think.

> There remains long term issue that needs a discussion about best UI for
> assigning keybindings (for keyboard configuration), for example whether to
> make it more similar to what MS Word 2007 does, or what Atom editor does.

I think there are great improvements in the page that Heiko pointed to. (Alas there is still work to do, as far as I am aware, to solve the negative effect of that re-design on customization of events).

Thanks so far!
Cor
Comment 9 Jakub Narębski 2015-07-13 07:44:23 UTC
(In reply to Cor Nouws from comment #8)
> Hi Jakub,
> 
> (In reply to Jakub Narębski from comment #7)
> 
> > I have created *this* issue because of annoying behavior wrt. adding
> > duplicated keybinding to the same function. This is a separate issue, and I
> > can raise a separate (and quick to fix) bug report.
> 
> Yes please do.

Created new bug report for adding a label / help text to keyboard configuration window as bug 92700 (in UI)
Comment 10 Robinson Tryon (qubit) 2016-08-25 05:39:02 UTC Comment hidden (obsolete)
Comment 11 Heiko Tietze 2018-01-11 09:40:53 UTC
To keep topics together I make this a dup of the older ticket. Situation has improved slightly with a search function but is far from being good. It's not forgotten however.

*** This bug has been marked as a duplicate of bug 52335 ***