Bug Hunting Session
Bug 92710 - Right-to-Left direction for Arabic is not working
Summary: Right-to-Left direction for Arabic is not working
Status: RESOLVED DUPLICATE of bug 85852
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.3 rc
Hardware: Other Mac OS X (All)
: highest normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
: 92989 93712 94585 (view as bug list)
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2015-07-13 17:52 UTC by Mohammed Rahawi
Modified: 2017-11-04 09:23 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Right-to-Left direction for Arabic is not working (642.17 KB, video/mp4)
2015-07-30 00:45 UTC, Mohammed Rahawi
Details
Video demonostrating the bug in LO 5.0.0 that renders it incmpatible with Arabic (1.28 MB, video/mp4)
2015-09-01 16:27 UTC, Mohammed Rahawi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mohammed Rahawi 2015-07-13 17:52:59 UTC
Right-t-Left direction for Arabic is not working in the the latest release, 5.0.0.3. It works fine in the earlier release, 5.0.0.2. Something happened in this release to break the support for Arabic. When you switching the direction to RTL, the cursor goes to the right but the direction of the text does not change!
Comment 1 Alex Thurgood 2015-07-23 17:34:22 UTC
Can not reproduce on

Version: 5.1.0.0.alpha1+
Build ID: 06f65a10aec23f4442bd42d1d117d0e8d648c52a
Locale: fr-FR (fr.UTF-8)

with OSX 10.10.4 and AZERTY keyboard Arabic system layout

Activated CTL for document only within LibreOffice language setup

The only thing I do notice is that the cursor always remains on the right hand side, but as far as I can remmeber, this is a known problem. When I type words, or sequences of characters with spaces however, they appear on the left, so at least in master build this is worksforme.
Comment 2 tommy27 2015-07-23 18:27:50 UTC
@Mohamme
try resetting the user profile
https://wiki.documentfoundation.org/UserProfile
and tell if bug persists
Comment 3 Mohammed Rahawi 2015-07-24 21:49:30 UTC
(In reply to Alex Thurgood from comment #1)
> Can not reproduce on
> 
> Version: 5.1.0.0.alpha1+
> Build ID: 06f65a10aec23f4442bd42d1d117d0e8d648c52a
> Locale: fr-FR (fr.UTF-8)
> 
> with OSX 10.10.4 and AZERTY keyboard Arabic system layout
> 
> Activated CTL for document only within LibreOffice language setup
> 
> The only thing I do notice is that the cursor always remains on the right
> hand side, but as far as I can remmeber, this is a known problem. When I
> type words, or sequences of characters with spaces however, they appear on
> the left, so at least in master build this is worksforme.

The cursor stay to right hand side and pushes the text to the left hand side! This bug started with Version: 5.0.1.0. I tried Version: 5.0.0.2 and there is no problem with this Version or Version 4.4.5.1.
Comment 4 Mohammed Rahawi 2015-07-26 14:30:34 UTC
I just tested versions 5.0.0.2 and 5.0.0.4. 5.0.0.2 works great with right to left direction. But version 5.0.0.4 does not support RTL! What give?
Comment 5 Yousuf Philips (jay) (retired) 2015-07-29 18:40:53 UTC
Works fine for me on Windows.

Version: 5.0.0.4
Build ID: cf112dc905650fb985306a7a03d2fe3fcc6c978f
Locale: en-US (en_US)

Mohammed can you do a screencast to demonstrate the problem. Some free screencast apps for mac are screencast-o-matic.com, jing, or screenr.com. Can you also copy and paste the build information found in the Help > About LibreOffice dialog box into your next comment.
Comment 6 V Stuart Foote 2015-07-29 21:50:09 UTC
*** Bug 92989 has been marked as a duplicate of this bug. ***
Comment 7 Mohammed Rahawi 2015-07-30 00:41:45 UTC
(In reply to Yousuf (Jay) Philips from comment #5)
> Works fine for me on Windows.
> 
> Version: 5.0.0.4
> Build ID: cf112dc905650fb985306a7a03d2fe3fcc6c978f
> Locale: en-US (en_US)
> 
> Mohammed can you do a screencast to demonstrate the problem. Some free
> screencast apps for mac are screencast-o-matic.com, jing, or screenr.com.
> Can you also copy and paste the build information found in the Help > About
> LibreOffice dialog box into your next comment.

It's Build ID: cf112dc905650fb985306a7a03d2fe3fcc6c978f.
Comment 8 Mohammed Rahawi 2015-07-30 00:45:33 UTC
Created attachment 117525 [details]
Right-to-Left direction for Arabic is not working
Comment 9 Mohammed Rahawi 2015-07-30 00:52:56 UTC
(In reply to Mohammed Rahawi from comment #7)
> (In reply to Yousuf (Jay) Philips from comment #5)
> > Works fine for me on Windows.
> > 
> > Version: 5.0.0.4
> > Build ID: cf112dc905650fb985306a7a03d2fe3fcc6c978f
> > Locale: en-US (en_US)
> > 
> > Mohammed can you do a screencast to demonstrate the problem. Some free
> > screencast apps for mac are screencast-o-matic.com, jing, or screenr.com.
> > Can you also copy and paste the build information found in the Help > About
> > LibreOffice dialog box into your next comment.
> 
> It's Build ID: cf112dc905650fb985306a7a03d2fe3fcc6c978f.

But it does not work on the Mac. I tested on OS 10.9.5 and OS 10.10.4.
You can see from the screen cast the cursor does not move when you hit the space bar but instead it drags the text to the left! In version 5.0.0.2 works fine.
Comment 10 Yousuf Philips (jay) (retired) 2015-07-30 14:44:55 UTC
(In reply to Mohammed Rahawi from comment #7)
> It's Build ID: cf112dc905650fb985306a7a03d2fe3fcc6c978f.

Can you provide the locale from the about dialog.

(In reply to Mohammed Rahawi from comment #8)
> Created attachment 117525 [details]
> Right-to-Left direction for Arabic is not working

The video shows that its acting like RTL is not enabled, though it is, and just align right was set.

(In reply to tommy27 from comment #2)
> try resetting the user profile
> https://wiki.documentfoundation.org/UserProfile
> and tell if bug persists

Have you tried doing this Mohammed?
Comment 11 Mohammed Rahawi 2015-07-30 15:25:36 UTC
(In reply to Yousuf (Jay) Philips from comment #10)
> (In reply to Mohammed Rahawi from comment #7)
> > It's Build ID: cf112dc905650fb985306a7a03d2fe3fcc6c978f.
> 
> Can you provide the locale from the about dialog.
> 
> (In reply to Mohammed Rahawi from comment #8)
> > Created attachment 117525 [details]
> > Right-to-Left direction for Arabic is not working
> 
> The video shows that its acting like RTL is not enabled, though it is, and
> just align right was set.
> 
> (In reply to tommy27 from comment #2)
> > try resetting the user profile
> > https://wiki.documentfoundation.org/UserProfile
> > and tell if bug persists
> 
> Have you tried doing this Mohammed?

The RTL IS enabled and event installed the Language pack for Arabic. If I revert to version 5.0.0.2, it works great. It's seems to me that RTL function is no longer function as of release version 5.0.03! You can confirm this by installing the two version on two different Macs and try them side by side. This is very serious bug for right to left languages.
Comment 12 Mohammed Rahawi 2015-07-30 15:41:16 UTC
(In reply to Yousuf (Jay) Philips from comment #10)
> (In reply to Mohammed Rahawi from comment #7)
> > It's Build ID: cf112dc905650fb985306a7a03d2fe3fcc6c978f.
> 
> Can you provide the locale from the about dialog.
> 
> (In reply to Mohammed Rahawi from comment #8)
> > Created attachment 117525 [details]
> > Right-to-Left direction for Arabic is not working
> 
> The video shows that its acting like RTL is not enabled, though it is, and
> just align right was set.
> 
> (In reply to tommy27 from comment #2)
> > try resetting the user profile
> > https://wiki.documentfoundation.org/UserProfile
> > and tell if bug persists
> 
> Have you tried doing this Mohammed?

I have done every thing including installing it on 3 different Macs with 2 different OSs. 
This is the last version that worked for me.
Version: 5.0.0.2
Build ID: a26d58f11b99b6aeddf7f7884effea188cc6e512
I am using this version now. The right to left function works like it supposed to! I don't know what happened in the later builds but the RTL function is not working in any version after this. I tested all of them including 5.1.0.0 Alpha.
Comment 13 Alex Thurgood 2015-07-30 17:08:31 UTC
To be clear, because the initial posting wasn't very clear as to what the exact problem was :

RTL with Arabic works on my system, but the cursor always stays on the right hand side. If this is the correct behaviour, then there is no bug. However, if the cursor is supposed to remain on the left hand side next to the newly appearing text, as with LTR text entry, then there is indeed a bug.

Unfortunately, not reading / writing any RTL language is a hindrance for me here as I'm unable to determine what is normal / expected behaviour.
See my comment 1 viz cursor position. If that is the buggy behaviour then the title should be changed to match.
Comment 14 Mohammed Rahawi 2015-07-30 19:35:49 UTC
(In reply to Alex Thurgood from comment #13)
> To be clear, because the initial posting wasn't very clear as to what the
> exact problem was :
> 
> RTL with Arabic works on my system, but the cursor always stays on the right
> hand side. If this is the correct behaviour, then there is no bug. However,
> if the cursor is supposed to remain on the left hand side next to the newly
> appearing text, as with LTR text entry, then there is indeed a bug.
> 
> Unfortunately, not reading / writing any RTL language is a hindrance for me
> here as I'm unable to determine what is normal / expected behaviour.
> See my comment 1 viz cursor position. If that is the buggy behaviour then
> the title should be changed to match.

The cursor is supposed to remain on the left hand side next to the newly appearing text just like LTR except it goes to the other oposite way. Also the cursor is supposed to move away from the text when you type spaces.
Comment 15 Robinson Tryon (qubit) 2015-08-06 14:18:54 UTC
(Should this bug still be in NEEDINFO status? --> is anything additional needed?)
Comment 16 Yousuf Philips (jay) (retired) 2015-08-06 15:42:48 UTC
Setting to NEW as the video Mohammed provided shows the problem, though it would be good to get another verification from a mac user.
Comment 17 Alex Thurgood 2015-08-06 17:47:35 UTC
See my confirmation in comment 1, where I incorrectly assumed that the cursor was supposed to remain on the RHS.
Comment 18 Mohammed Rahawi 2015-08-06 19:09:47 UTC
(In reply to Alex Thurgood from comment #17)
> See my confirmation in comment 1, where I incorrectly assumed that the
> cursor was supposed to remain on the RHS.

Hi Alex,
It would help you understand the problem if you just enable the RTL function on LO 4.4 and type a few words and many spaces at he end, then do the same thing using LO 5.0. You will see that the cursor will move away from the text and but the text will remain in the right hand side with LO 4.4. Where is in LO 5.0 the cursor stays next to the text but drags the text to the left hand side. This problem is making LO 5.0 incompatible with Arabic. You cannot type or edit text directly in LO 5.0. 
Hope this problem can be fixed. 

I am now using 5.0.0.2. Build ID: a26d58f11b99b6aeddf7f7884effea188cc6e512
This version does not have this problem.
Comment 19 Maxim Monastirsky 2015-08-27 13:23:56 UTC
*** Bug 93712 has been marked as a duplicate of this bug. ***
Comment 20 Maxim Monastirsky 2015-08-27 13:36:09 UTC
One thing that I noticed while watching the video, is that the status bar says "Hindi" (which is, according to Wikipedia, written LTR). So the first thing I would try is to open Tools->Options...->Language Settings->Languages, and set Arabic for "Complex text layout (CTL)". And also under LibreOffice Writer->Basic Fonts (CTL), make sure that the default fonts are ones that support Arabic.
Comment 21 Mohammed Rahawi 2015-08-27 23:27:44 UTC
(In reply to Maxim Monastirsky from comment #20)
> One thing that I noticed while watching the video, is that the status bar
> says "Hindi" (which is, according to Wikipedia, written LTR). So the first
> thing I would try is to open Tools->Options...->Language
> Settings->Languages, and set Arabic for "Complex text layout (CTL)". And
> also under LibreOffice Writer->Basic Fonts (CTL), make sure that the default
> fonts are ones that support Arabic.

I think that this is the problem.It doesn't change to Arabic from Hindi. When I set the Language> Settings and check the complex text layout(CTL), it shows Hindi as the default language. I Changed it to Arabic (Algeria). But in the status bar it still says Hindi. I checked again the Options...->Language> Settings->Languages, it say A: Arabic (Algeria). This might give a clue to the root of bug. It does change the language. But keep the default language. I have been using version 4.4 and version 5.0.0.2 prerelease. They work great. (In reply to Maxim Monastirsky from comment #19)
> *** Bug 93712 has been marked as a duplicate of this bug. ***
Comment 22 Yousuf Philips (jay) (retired) 2015-08-30 19:51:25 UTC
(In reply to Maxim Monastirsky from comment #20)
> One thing that I noticed while watching the video, is that the status bar
> says "Hindi" (which is, according to Wikipedia, written LTR). So the first
> thing I would try is to open Tools->Options...->Language
> Settings->Languages, and set Arabic for "Complex text layout (CTL)". And
> also under LibreOffice Writer->Basic Fonts (CTL), make sure that the default
> fonts are ones that support Arabic.

I can type arabic fine with Hindi mentioned in the statusbar, so that isnt the problem. The only thing needed to type arabic in LO is to switch the text direction to RTL (only possible in CTL is enabled) and enable the arabic keyboard. When a user switches to RTL, the text language will still be English, but when switching the keyboard to arabic, then LO automatically switches it to Hindi, though a user can easily change this in the text language status field context menu or in the character dialog. I had watched the video twice on 07-30 to check if Mohammed was doing it right and it looked correct to me.
Comment 23 Mohammed Rahawi 2015-09-01 16:27:42 UTC
Created attachment 118315 [details]
Video demonostrating the bug in LO 5.0.0 that renders it incmpatible with Arabic
Comment 24 Mohammed Rahawi 2015-09-01 16:34:04 UTC
(In reply to Yousuf (Jay) Philips from comment #22)
> (In reply to Maxim Monastirsky from comment #20)
> > One thing that I noticed while watching the video, is that the status bar
> > says "Hindi" (which is, according to Wikipedia, written LTR). So the first
> > thing I would try is to open Tools->Options...->Language
> > Settings->Languages, and set Arabic for "Complex text layout (CTL)". And
> > also under LibreOffice Writer->Basic Fonts (CTL), make sure that the default
> > fonts are ones that support Arabic.
> 
> I can type arabic fine with Hindi mentioned in the statusbar, so that isnt
> the problem. The only thing needed to type arabic in LO is to switch the
> text direction to RTL (only possible in CTL is enabled) and enable the
> arabic keyboard. When a user switches to RTL, the text language will still
> be English, but when switching the keyboard to arabic, then LO automatically
> switches it to Hindi, though a user can easily change this in the text
> language status field context menu or in the character dialog. I had watched
> the video twice on 07-30 to check if Mohammed was doing it right and it
> looked correct to me.

The problem is not typing Arabic. The problem is the cursor does not move away from the text like it supposed to. I just uploaded a second video that might show the problem better.
Comment 25 Yousuf Philips (jay) (retired) 2015-09-01 21:44:50 UTC
(In reply to Mohammed Rahawi from comment #23)
> Created attachment 118315 [details]
> Video demonostrating the bug in LO 5.0.0 that renders it incmpatible with
> Arabic

The behaviour seen here is what would happen if I switched text in LTR to right aligned and started typing. Its unfortunate that this would happen when RTL is enabled on mac.
Comment 26 Mohammed Rahawi 2015-09-01 22:37:28 UTC
(In reply to Yousuf (Jay) Philips from comment #25)
> (In reply to Mohammed Rahawi from comment #23)
> > Created attachment 118315 [details]
> > Video demonostrating the bug in LO 5.0.0 that renders it incmpatible with
> > Arabic
> 
> The behaviour seen here is what would happen if I switched text in LTR to
> right aligned and started typing. Its unfortunate that this would happen
> when RTL is enabled on mac.

It is unfortunate. However, I'm using Version: 5.0.0.2
Build ID: a26d58f11b99b6aeddf7f7884effea188cc6e512 and this build does not have this bug. Also 4.4 all builds do not have this bug.
Comment 27 Alex Thurgood 2015-09-30 07:56:31 UTC
*** Bug 94585 has been marked as a duplicate of this bug. ***
Comment 28 Mohammed Rahawi 2015-12-08 19:07:43 UTC
(In reply to Yousuf (Jay) Philips from comment #25)
> (In reply to Mohammed Rahawi from comment #23)
> > Created attachment 118315 [details]
> > Video demonostrating the bug in LO 5.0.0 that renders it incmpatible with
> > Arabic
> 
> The behaviour seen here is what would happen if I switched text in LTR to
> right aligned and started typing. Its unfortunate that this would happen
> when RTL is enabled on mac.

Any chance this bug is going to be fixed in the future? just tried LO 5.1.0 beta2. Still not usable for RTL Languages.
Comment 29 Robinson Tryon (qubit) 2015-12-14 05:32:39 UTC Comment hidden (obsolete)
Comment 30 Alex Thurgood 2016-09-05 10:06:04 UTC
*** Bug 93062 has been marked as a duplicate of this bug. ***
Comment 31 eisa01 2016-09-12 19:31:53 UTC
Not really knowing Arabic, but this seems eerily similar to bug 85852. This regressed between the same release candidates, and when I try to replicate the videos in the same commits that 85852 regressed, there is a noticeable difference in how they behave.

CCing Norbert for that reason
Comment 32 Alex Thurgood 2016-09-23 10:00:55 UTC
(In reply to eisa01 from comment #31)
> Not really knowing Arabic, but this seems eerily similar to bug 85852. This
> regressed between the same release candidates, and when I try to replicate
> the videos in the same commits that 85852 regressed, there is a noticeable
> difference in how they behave.
> 
> CCing Norbert for that reason




I would tend to agree. Thanks for pinning this down. Setting this report as DUP of 85852.

*** This bug has been marked as a duplicate of bug 85852 ***
Comment 33 Lior Kaplan 2017-11-04 09:23:48 UTC
Fixed in 5.3.0 per the info in bug #85852