Download it now!
Bug 92724 - LibreOffice does not render word document correctly, 4 pages instead of 3 as in word
Summary: LibreOffice does not render word document correctly, 4 pages instead of 3 as ...
Status: RESOLVED DUPLICATE of bug 64372
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.3 rc
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-14 08:23 UTC by Jack
Modified: 2015-07-15 13:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
File which causes the failure (26.28 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-07-14 08:23 UTC, Jack
Details
patched document.xml (2.67 KB, application/xml)
2015-07-14 13:06 UTC, Jack
Details
Patched Word (16.17 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-07-14 13:06 UTC, Jack
Details
Stripped down version (15.78 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-07-15 11:41 UTC, Jack
Details
problematic document.xml (1.86 KB, application/xml)
2015-07-15 12:01 UTC, Jack
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jack 2015-07-14 08:23:27 UTC
Created attachment 117225 [details]
File which causes the failure

When opening the attached document in Word, there are 3 pages shown, but LibreOffice shows four pages, one of them empty. This page is not shown in Word.
LibreOffice 5.x is the first version affected by this bug.

Furthermore, LibreOffice "flickers" when scrolling.

Any suggestions?
Comment 1 Jack 2015-07-14 08:50:41 UTC
When I delete the first section break in Word, LibreOffice shows the document correctly!
Comment 2 steve -_- 2015-07-14 10:49:55 UTC
Adjusting Importance. This is not critical at all:
https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

Thejack: thanks for your report though. I am confirming this issue.

OS X 10.10.4
LO Version: 5.1.0.0.alpha1+
Build ID: 122a15f4a6c09d35db58fe3a7b943b5ea79cbe65
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-07-09_23:56:41
Locale: de-DE (de.UTF-8)


Also in 4.4.4.3.
Comment 3 Jack 2015-07-14 13:05:16 UTC
Thank, you. I have done a little bit of research, and here is what I noticed:

In my opinion, the issue is caused due line 23 in the document.xml inside the word folder. When I comment this line out, everything works find. I have attached a pathed document.xml and a patched .docx(without the line). Can anybody give me some pointers what the following line does?
<w:type w:val="continuous"/>

Regards,
Jack
Comment 4 Jack 2015-07-14 13:06:21 UTC
Created attachment 117228 [details]
patched document.xml
Comment 5 Jack 2015-07-14 13:06:47 UTC
Created attachment 117229 [details]
Patched Word
Comment 6 Timur 2015-07-15 10:11:24 UTC
Problems with rendering are obvious, but please first search for already reported bugs before reporting and conforming. 
Opens 3 pages in LO 3.4. Looks like a duplicate of Bug 64372 to me. If you agree. please mark as such.
Comment 7 Jack 2015-07-15 11:41:00 UTC
Created attachment 117245 [details]
Stripped down version

I don't know. It may be the same reason, but the documents are completly different.
I have attached a stripped down of my document.
Comment 8 Jack 2015-07-15 12:01:09 UTC
Created attachment 117248 [details]
problematic document.xml
Comment 9 Jack 2015-07-15 13:50:42 UTC
(In reply to Timur from comment #6)
> Problems with rendering are obvious, but please first search for already
> reported bugs before reporting and conforming. 
> Opens 3 pages in LO 3.4. Looks like a duplicate of Bug 64372 to me. If you
> agree. please mark as such.

You are right. I was able to reduce Jared's documents.txt to mine.

*** This bug has been marked as a duplicate of bug 64372 ***