Download it now!
Bug 92751 - Converting formulae to entire row and entire column when limit exceeds bounds
Summary: Converting formulae to entire row and entire column when limit exceeds bounds
Status: CLOSED DUPLICATE of bug 92779
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.0.3 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-15 04:19 UTC by Óvári
Modified: 2015-12-10 07:49 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Óvári 2015-07-15 04:19:58 UTC
Version: 5.0.0.3 (x64)
Build ID: f79b5ba13f5e6cbad23f8038060e556217e66632

1. Open LibreOffice Calc
2. In cell A2 enter: =SUM($B1:B1048573)
3. Select rows 4 to 14
4. Right click on any row heading from 4 to 14
5. Insert Rows Above
6. Formula in cell A2 shows: =SUM($B1:B#REF!)
   Expected formula in cell A2: =SUM($B:B)

Unfortunately, bug also occurs when entering columns which exceed column limit.

Thank you
Comment 1 Jacques Guilleron 2015-07-15 08:14:53 UTC
Hi Óvári,

I confirm with LO  5.0.0.3
Build ID: f79b5ba13f5e6cbad23f8038060e556217e66632
Windows 7 Home Premium
Comment 2 Eike Rathke 2015-07-15 11:14:33 UTC
That's normal behaviour and always was the case. Inserting 4 rows will shift the reference end row beyond 1048576 (i.e. 1048577). There's no automatic conversion to $B:B in between and should not be.
Comment 3 Eike Rathke 2015-07-15 11:15:23 UTC
*** Bug 92759 has been marked as a duplicate of this bug. ***
Comment 4 Óvári 2015-07-15 22:59:05 UTC
Thank you Eike for your comment.

Perhaps LibreOffice (LO) documentation user documentation could state that:
1. LO Calc operates differently to MS Excel as it does not have automatic conversion to absolute/relative entire row/column; and
2. LO Calc produces an #REF! error, while MS Excel converts the range to absolute/relative entire row/column notation.
Comment 5 Óvári 2015-12-10 07:49:28 UTC
Fix in bug 92779 incorporates this bug. Thank you

*** This bug has been marked as a duplicate of bug 92779 ***