Download it now!
Bug 92774 - Can't add word to dictionary or use other options when list of choices is very long and have to scroll
Summary: Can't add word to dictionary or use other options when list of choices is ver...
Status: RESOLVED DUPLICATE of bug 92702
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta2
Hardware: x86-64 (AMD64) All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2015-07-15 20:13 UTC by John
Modified: 2016-08-30 15:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John 2015-07-15 20:13:19 UTC
Win 7 Ultimate x64; LO 5.x x86

Where a short acronym e.g. AVM is not in the dictionary, right clicking may produce a very long list of options. It is necessary to scroll down to the options for handling this - ignore, add to dictionary etc. but after scrolling none of the options work. If the word is such that there is only a short list with no need for scrolling, then the options work normally.

I did not spot when this first appeared; I have 5.0.0.2 and 5.0.0.3 and both exhibit this but I never noticed it in 4.x.

Related to this is the very long list of spelling options that short acronyms etc. produce. Some refinement of the logic used to select options would be a good idea as many of the options offered as spelling alternatives are very unlikely, or maybe the list should be restricted to the, say, 10 most likely.
Comment 1 tommy27 2015-07-16 03:02:04 UTC
bug confirmed under Win8.1 x64 using 5.1.0.0.alpha1+
Build ID: d3b6f3790953bdfeaeebcd3ba9ec370d94ca4ebf
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-07-09_00:11:55
Locale: en-US (it_IT)

LibO 4.4.3.2 works fine so it's a 5.x regression
status NEW


(In reply to John from comment #0)

> Related to this is the very long list of spelling options that short
> acronyms etc. produce. Some refinement of the logic used to select options
> would be a good idea as many of the options offered as spelling alternatives
> are very unlikely, or maybe the list should be restricted to the, say, 10
> most likely.

I agree with you. You should open a separate bug report about this telling it's an enhancement request and ask to limit the number of suggestions to 10,20 or whatever. please, put me on the CC list when you do it.
Comment 2 Joel Madero 2015-07-16 04:08:14 UTC
I just tried in Linux and I don't get a "very long list of options" for AVM - my list is 12 entries and requires no scrolling. I even tested at incredibly low resolution to try to force it to allow me to scroll and it still wasn't long enough to allow me to scroll. Are there other words that you can think of that might allow me to do the same thing? If I can test in Linux I'll bibisect it but with the given word I'm unable to do so. Thanks
Comment 3 tommy27 2015-07-16 05:32:58 UTC
@Joel
try a simple 2 digits combination that is not in your dictionary like "hk"

it will generate a long list of suggestions
Comment 4 Robert Großkopf 2015-07-16 05:50:44 UTC
Tried this with "AVW" - 7 options, no scrolling
Tried it with "hk" - 7 options, no scrolling

Which language do you use. Have tried much more, but didn't get more than 9 options ...

My system: OpenSUSE 13.2 64bit rpm Linux, LO 5.0.0.3
Comment 5 tommy27 2015-07-16 08:59:26 UTC
try "hk" with Italian... I got more that 30 suggestions with that
Comment 6 wope 2015-07-16 09:02:11 UTC
in german, i tried this with the words jo and me, I must scroll. everthing was ok, i can add the word to the dictionary and ignore, and ...
my System: OpenSuse 13.2, 64Bit, LO 5.0.0.3
Comment 7 tommy27 2015-07-16 09:13:03 UTC
seems like it's a Windows only bug
Comment 8 Carlos Rodriguez 2015-07-16 10:50:12 UTC
I can confirm on Debian 8 (jessie) with just "hk" word and choosing English (USA) language for selection and:

Version: 5.1.0.0.alpha1+
Build ID: 9be553f4c61f220ebbe212dc76cb9cce4ae1c106
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-07-13_22:45:19
Locale: es-ES (es_ES.UTF-8)

It's important to mention that if I change the language for this selection, the bug is not reproducible.

Works also fine under:

Version: 5.0.1.0.0+
Build ID: b0153639c17d40061480a7bbde11fa0249e3051f
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-5-0, Time: 2015-07-14_03:50:43
Locale: es-ES (es_ES.UTF-8)

and

Version: 4.4.6.0.0+
Build ID: 865afb6ed25891129efb6907595c892e417a191a
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-4, Time: 2015-07-14_00:39:03
Locale: es_ES.UTF-8
Comment 9 tommy27 2015-07-16 11:58:23 UTC
@Carlos
good catch. so it affects Linux as well and can be bibisected.

the issue is reproducible with certain languages and not in others.

I retested and the menu items do not work with English (USA) but work fine with Italian.
Comment 10 tommy27 2015-07-19 08:04:27 UTC
> 
> (In reply to John from comment #0)
> 
> > Related to this is the very long list of spelling options that short
> > acronyms etc. produce. Some refinement of the logic used to select options
> > would be a good idea as many of the options offered as spelling alternatives
> > are very unlikely, or maybe the list should be restricted to the, say, 10
> > most likely.
> 
> I agree with you. You should open a separate bug report about this telling
> it's an enhancement request and ask to limit the number of suggestions to
> 10,20 or whatever. please, put me on the CC list when you do it.

I filed bug 92824 about the long list issue.
Comment 11 Robinson Tryon (qubit) 2015-12-14 05:32:49 UTC Comment hidden (obsolete)
Comment 12 Joel Madero 2015-12-20 16:24:18 UTC
Can someone who is seeing this problem please try to bibisect it? Right now it's sitting in bibisectRequest stagnant. 

I just tested with "hk" with 4.4 and 5.0, both gave me a list of 16 options...no scrolling (maybe because my screen resolution is high?)

Does "hk" with English (USA) locale produce two different results between 4.4 and 5.0? Can we get some concrete numbers as to how many entries there are.

https://wiki.documentfoundation.org/QA/Bibisect/Linux
Comment 13 Joel Madero 2015-12-20 16:24:57 UTC
Just tested 3.3 and I get 17 options for "hk"
Comment 14 Caolán McNamara 2016-08-30 15:43:39 UTC
I installed windows version 5.1.0.1 which has a dictionary with loads of single char entries for "hq" in English and it can't be reproduced there. The menu scrolls and works fine.

This however was reproduced by tommy27 with 5.1.0.0lapha1+ and I see that bug 92702 was fixed between 5.1.0.0 and 5.1.0.1 and it is "unable to select menu items that were initially off-screen". Reverting that fix indeed creates a menu for these choice entries where the offscreen entries don't work when scrolled onto the screen.

There was also backports of this fix to to 5.0.X series. I'm pretty sure this is a duplicate of that, now fixed, problem

*** This bug has been marked as a duplicate of bug 92702 ***