Bug 92814 - FORMATTING and VIEWING: Allow display of Print border outline in Worksheet view.
Summary: FORMATTING and VIEWING: Allow display of Print border outline in Worksheet view.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Page-Break
  Show dependency treegraph
 
Reported: 2015-07-18 18:15 UTC by Drizzt
Modified: 2020-01-09 08:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Drizzt 2015-07-18 18:15:15 UTC
One useful feature would be to enable the toggle for, (or always display) a print border outline in a worksheet showing where the current page layout settings will print the worksheet.  In Excel, when you attempt to print a worksheet, a dotted line will appear to signify how each section of the worksheet will fit in a page.  This is more useful than having to jump back and forth between the Print Preview screen.

In Excel, this page layout dotted line only appears after attempting to print a worksheet.  The same functionality could be implemented in Calc, or simply provide a View toggle for this feature.
Comment 1 Drizzt 2015-07-18 18:25:17 UTC
After additional testing, it does appear that the page layout border does appear.  However, it doesn't show immediately after attempting to print and then canceling to return to the worksheet.  You have to scroll around the worksheet in order to get the border line to refresh and start appearing.  For example, if you page down, the border line will appear.  Then when you page back up, the screen refresh causes the border to appear.

The page separation border line should just appear and refresh immediately after attempting to print.  I have changed this to a minor bug since the feature already exists but isn't functioning correctly.
Comment 2 Jean-Baptiste Faure 2015-07-19 18:12:49 UTC
Did you try menu Tools > Options > LibreOffice Calc > View > Page breaks checkbox ?

Best regards. JBF
Comment 3 Drizzt 2015-07-31 19:51:48 UTC
I did try the View Page Breaks option, which is actually checked by Default.  However, this works similarly to Excel, where the page breaks do not appear until you first attempt to print.  This functionality is fine.  However, the page breaks in Calc do not actually display until you scroll around in the worksheet, due to a screen refresh issue, after attempting to Print.  You shouldn't have to scroll around the screen to see the Page Breaks.

This is the scenario:
- Open a spreasheet.
- Open Print page.  Cancel the print page.
- Page Breaks do not appear.
- Scroll down the screen.
- Page Breaks start appearing on the worksheet as the new data rows appear.  Instead this should be corrected so that the Page breaks should appear for the currently displayed area of the worksheet.
Comment 4 Joel Madero 2015-10-18 01:30:06 UTC
I can partially confirm this so I'm pushing it to NEW. I actually never get the grid after going to print -> exit -> then scroll. This is despite the checkmark being on.

Ubuntu 15.04 x64
LibreOffice 5.0.2.2

New;
Minor - can slow down but will not prevent high quality work;
Low - default seems appropriate here.


Seems strange to me that the option is checked by default but we don't always see the print borders (immediately after opening spreadsheet).
Comment 5 QA Administrators 2016-11-08 11:27:51 UTC Comment hidden (obsolete)
Comment 6 Jean-Baptiste Faure 2016-11-11 09:49:45 UTC
(In reply to Joel Madero from comment #4)
> [...]
> Seems strange to me that the option is checked by default but we don't
> always see the print borders (immediately after opening spreadsheet).

I guess it is because the print borders depend on the printer and its settings. If LO does not know which printer is to be used, it can't calculate the print borders.

Best regards. JBF
Comment 7 QA Administrators 2018-07-14 02:47:08 UTC Comment hidden (obsolete)
Comment 8 Cor Nouws 2020-01-09 08:55:18 UTC
Start a new spreadsheet in Version: 6.5.0.0.alpha0+
Build ID: 084d546858ef05c0c71c9fe6b3bca7961b62899e
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-12-27_18:00:25
Locale: nl-NL (en_US.UTF-8); UI-Language: en-US
Calc: threaded

and you'll see dotted lines for the print-borders.
So this is working now.