Bug 92823 - FORMATTING: styles and formatting function does not work (see comment 19)
Summary: FORMATTING: styles and formatting function does not work (see comment 19)
Status: RESOLVED DUPLICATE of bug 83546
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-19 04:18 UTC by andréb
Modified: 2015-08-17 05:27 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
my profile (freshly recreated + reconfigured) (665.98 KB, application/zip)
2015-07-29 01:40 UTC, andréb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andréb 2015-07-19 04:18:54 UTC
Attempts to invoke the styles_and_formatting function in Calc and Writer have no effect.
a) clicking the button in the format bar does nothing, even though mouse-over shows the button outline as happens with other buttons
b) pressing f11 does nothing
c) selecting menu item format : styles and formatting just returns to the document without doing anything.

This is a regression, as it worked in all previous versions of Libreoffice that I have used.

I have classified it as priority:high, as there is no other way to set global formatting.
It probably affects modules other than Calc and Writer, not tested.

It may be related to bug 91319, which reports somewhat different symptoms for  MacOSX.
Comment 1 Joel Madero 2015-07-19 04:49:52 UTC
I'm going to lower this just to reflect our internal objective standards:

Minor - can slow down but will not prevent high quality work;
High - seems appropriate if it can be confirmed


Major is pretty much retained for crashers and data loss. 

Can you please describe clear steps a bit better on how to reproduce? I use styles daily with 4.4 and never seen any issues so wondering if I'm missing something. Throwing into NEEDINFO - please just provide clear repro steps and set the bug to UNCONFIRMED and we'll go from there. 


Thanks!

Also might be worth resetting your profile just in case: https://wiki.documentfoundation.org/UserProfile
Comment 2 Cor Nouws 2015-07-19 06:31:06 UTC
Thanks for your report André
All works fine for me on Linux 32 bits.
Maybe there is something odd with your userprofile.
See https://wiki.documentfoundation.org/UserProfile
Please try with using a fresh one.
Or maybe the side bar is collapsed, so that you miss the pane style and formatting. For help with questions on the user interface, see http://www.libreoffice.org/get-help/community-support/
Anyway, I set as WorksForMe.
Cheers - Cor
Comment 3 andréb 2015-07-20 03:38:05 UTC
(In reply to Joel Madero from comment #1)
> I'm going to lower this just to reflect our internal objective standards:
> 
> Minor - can slow down but will not prevent high quality work;
> High - seems appropriate if it can be confirmed
> 
> 
> Major is pretty much retained for crashers and data loss. 
> 
> Can you please describe clear steps a bit better on how to reproduce? I use
> styles daily with 4.4 and never seen any issues so wondering if I'm missing
> something. Throwing into NEEDINFO - please just provide clear repro steps
> and set the bug to UNCONFIRMED and we'll go from there. 

I gave exactly the steps to reproduce.  Attempts to invoke the function simply did not respond.  More details below.

> 
> Thanks!
> 
> Also might be worth resetting your profile just in case:
> https://wiki.documentfoundation.org/UserProfile

Resetting my profile corrected the problem with the function, but introduced another.
After redoing all my configuration (with one exception), I find that one tool bar function that I use frequently is no longer available.
It is automatic line wrap in cells in calc.  ("renvoi de ligne automatique" in my copy of Libo in french.)
All the other formatting tool bar functions that I use are still available.

This function is still available under menu : format : cells : alignment tab, in a check box at the bottom of the page.
But it is considerably more time consuming to access the function that way.

Should I open a new bug or change this bug to this problem ?
Comment 4 andréb 2015-07-20 03:44:46 UTC
(In reply to Cor Nouws from comment #2)
> Thanks for your report André
> All works fine for me on Linux 32 bits.
> Maybe there is something odd with your userprofile.
> See https://wiki.documentfoundation.org/UserProfile
> Please try with using a fresh one.
> Or maybe the side bar is collapsed, so that you miss the pane style and
> formatting. For help with questions on the user interface, see
> http://www.libreoffice.org/get-help/community-support/
> Anyway, I set as WorksForMe.
> Cheers - Cor

You were correct in suspecting the user profile.
It was probably caused by a regression which I describe in comment #3.
(I had recently upgraded my distro of Linux, bringing the more recent version of Libreoffice.  Before the upgrade, I had no problem.)
Comment 5 andréb 2015-07-28 22:06:27 UTC
Reopening as the problem was only temporarily working after resetting my profile.
When I reconfigured my profile to work as I wanted (how I had it for numerous years), the style and formatting function no longer works.
My changes to my profile were mostly just adding a few things to the formatting tool bar, as well as removing some functions never used.  I had probably not changed it since Libreoffice started as a fork of Openoffice a few years ago.  And up to the current version (4.4.2), everything had worked.

It is true that in the (relatively new) side bar this function is accessible.
However none of the other means of accessing the function work.
As well, using the side bar hides a significant part of the spreadsheet, which is problematic in a small window.  And significantly slower than using the button in a tool bar.
Note that including menu:format:styles&formatting -and- pressing F12, there are 3 means of accessing this function that DO NOT WORK.

So this is a regression from version 4.3.6.
Comment 6 Joel Madero 2015-07-28 22:15:00 UTC
REOPENED is incorrect - setting to NEEDINFO. Please attach a zip file containing your profile and then set to UNCONFIRMED (please don't set to REOPENED). Thanks!
Comment 7 andréb 2015-07-29 01:40:31 UTC
Created attachment 117509 [details]
my profile (freshly recreated + reconfigured)
Comment 8 andréb 2015-07-29 01:43:05 UTC
my profile with path .config/libreoffice/4/user/*
Comment 9 Buovjaga 2015-08-01 14:52:54 UTC
5.0 final will be released next Wednesday. Maybe you could try recreating your toolbar setup in it and see what happens. If you don't want to replace 4.4 yet: https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 10 Joel Madero 2015-08-01 15:42:36 UTC
(In reply to andréb from comment #0)
> Attempts to invoke the styles_and_formatting function in Calc and Writer
> have no effect.
> a) clicking the button in the format bar does nothing, even though
> mouse-over shows the button outline as happens with other buttons
> b) pressing f11 does nothing
> c) selecting menu item format : styles and formatting just returns to the
> document without doing anything.
> 


I'm sorry but I have to put this in NEEDINFO again. What we need you to do is better describe the issue. Saying things like "clicking 'the button in the format bar" is not very helpful. What button are you referring to? What I did:

1. Replaced my profile with yours; (btw you have a really interesting setup...completely dysfunctional for my purposes but interesting none the less) :)

2. Opened calc;

3. Went to View -> Toolbar -> Formatting

I then proceeded to click on every single button and they all worked

4. Then I tried "background color" (assumed this was "fill") from standard toolbar;

Worked fine

5. Then I tried the opening the styles and formatting dialog - this indeed failed.


Given that 1 instruction I don't understand, 1 (if I understand correctly) it works fine, and the last one is broken as described...I'm tempted to ask to separate this into three bugs but for now NEEDINFO - then please set to UNCONFIRMED (not REOPENED).

Thanks for your patience, feel free to jump into the QA chat to work things out live: http://webchat.freenode.net/?channels=libreoffice-qa
Comment 11 andréb 2015-08-01 17:43:10 UTC
(In reply to Joel Madero from comment #10)
> (In reply to andréb from comment #0)
> > Attempts to invoke the styles_and_formatting function in Calc and Writer
> > have no effect.
> > a) clicking the button in the format bar does nothing, even though
> > mouse-over shows the button outline as happens with other buttons
> > b) pressing f11 does nothing
> > c) selecting menu item format : styles and formatting just returns to the
> > document without doing anything.
> > 
> 
> 
> I'm sorry but I have to put this in NEEDINFO again. What we need you to do
> is better describe the issue. Saying things like "clicking 'the button in
> the format bar" is not very helpful. What button are you referring to? What
> I did:
> 
> 1. Replaced my profile with yours; (btw you have a really interesting
> setup...completely dysfunctional for my purposes but interesting none the
> less) :)

But mostly functional for my purposes until several regressions in 3.4.x
 
> 2. Opened calc;
> 
> 3. Went to View -> Toolbar -> Formatting
> 
> I then proceeded to click on every single button and they all worked
> 
Why ?  I never suggested a problem in the format menu.

> 4. Then I tried "background color" (assumed this was "fill") from standard
> toolbar;
> 
> Worked fine

Nor there.

> 5. Then I tried the opening the styles and formatting dialog - this indeed
> failed.

Exactly.
You did notice the "styles and formatting function" in the summary and the beginning of the description, as well as "format bar" in the description ?
Sorry if that sounds a little sarcastic, but I also mentioned in subsequent comments that every other button (that I had configured) in the format tool bar worked.

Also note that I mentioned that menu:format:style_and_formatting and F11 don't permit access to the style_and_formatting function.

As for the other regression, the line wrap function that is no longer available for tool bars (which affects both global and individual settings), I suspect that it is due a change done at the same time as the first regression.
Both regressions affect formatting.
I could open another bug for that if it would help.

> Given that 1 instruction I don't understand, 1 (if I understand correctly)
> it works fine, and the last one is broken as described...I'm tempted to ask
> to separate this into three bugs but for now NEEDINFO - then please set to
> UNCONFIRMED (not REOPENED).
> 
> Thanks for your patience, feel free to jump into the QA chat to work things
> out live: http://webchat.freenode.net/?channels=libreoffice-qa

Sorry, but I have been a little low in patience lately ...
Comment 12 andréb 2015-08-01 17:46:53 UTC
(In reply to Beluga from comment #9)
> 5.0 final will be released next Wednesday. Maybe you could try recreating
> your toolbar setup in it and see what happens. If you don't want to replace
> 4.4 yet: https://wiki.documentfoundation.org/Installing_in_parallel/Linux

Thanks for the suggestion.
I did that quite a while back for another problem, and it did help a lot.
Comment 13 Joel Madero 2015-08-01 17:47:28 UTC
I'm removing myself from CC as you again failed to describe the issue - using phrases like "push the button" (WHAT BUTTON)...no time to continue going back and forth. Maybe someone else will triage it
Comment 14 andréb 2015-08-01 23:37:07 UTC
(In reply to Joel Madero from comment #10)
> ...
> 
> 5. Then I tried the opening the styles and formatting dialog - this indeed
> failed.

This point confirms bug report, so setting to "new" = confirmed.
(The preceding points did not address the problem reported.)
Comment 15 Cor Nouws 2015-08-10 20:42:06 UTC
(In reply to andréb from comment #14)
> (In reply to Joel Madero from comment #10)
> > ...
> > 
> > 5. Then I tried the opening the styles and formatting dialog - this indeed
> > failed.
> 
> This point confirms bug report, so setting to "new" = confirmed.
> (The preceding points did not address the problem reported.)

I've re-read your original report and notice you wrote three points of failure there around the S&F dlg.
Wrt the #5 above here: no idea what you have done with the user profile (din't study it, sorry). But all functions for you with a fresh user profile. And for me just with the profile I use. I guess, if other ran into the same problem, we would have been flooded by similar reports ;)
So sorry, but the only sensible thing is  to resolve as WorksForMe.
Comment 16 andréb 2015-08-11 04:50:06 UTC
(In reply to Cor Nouws from comment #15)
> (In reply to andréb from comment #14)
> > (In reply to Joel Madero from comment #10)
> > > ...
> > > 
> > > 5. Then I tried the opening the styles and formatting dialog - this indeed
> > > failed.
> > 
> > This point confirms bug report, so setting to "new" = confirmed.
> > (The preceding points did not address the problem reported.)
> 
> I've re-read your original report and notice you wrote three points of
> failure there around the S&F dlg.
> Wrt the #5 above here: no idea what you have done with the user profile
> (din't study it, sorry). But all functions for you with a fresh user profile.

My saying in comment 3 that the S&F function worked, it is likely due to testing the wrong thing, using the context menu to change a single cell.  (I really wanted it to work.)
Since the S&F function in the tool bar no longer worked after just deactivating/activating a few functions predefined by default in the tool bar, by unchecking/checking the associated check box.

> And for me just with the profile I use. I guess, if other ran into
> the same problem, we would have been flooded by similar reports ;)
> So sorry, but the only sensible thing is  to resolve as WorksForMe.

Looking at your comment #2, you mention being able to use the (relatively new) side bar to access the S&F dialog.
I suspect that you haven't tested the S&F dialog in the format tool bar, which is where I reported the error occurring.
As well, you give no indication of having tested the alternate menu:format:S&F and F11 means of accessing this function. Please note that these 2 methods of accessing the function are not configurable.

Could you confirm that you have actually tested these means of accessing the S&F function ?
Otherwise you are just saying that something other than the problem reported works for you.
Comment 17 andréb 2015-08-17 02:31:08 UTC
This problem still exists as reported, in Libo 5.0.0.5

Tested in a parallel installation downloaded from Libo site, Linux x86 version.
A separate UserInstallation was defined in the .../libreoffice/program/bootstraprc file, with no changes made to the default configuration.

So reopening, as problem still exists.
Whoever classed it as "worksforme" must have not tested the problem as defined, as one of the 3 symptoms (pressing F11) should not be affected by the configuration.

Note that it was already confirmed in point 5 of comment 10.
Comment 18 V Stuart Foote 2015-08-17 03:17:03 UTC
Sorry, no regression here, just progress in the UI which you've not kept up with.

The Styles and Formatting dialog was moved into the Sidebar effective with 4.3 release.

The F11 keyboard shortcut will activate the Styles and Formatting deck in the Sidebar

The Styles and Formatting button on the Formatting menu has been supressed, but if used it also launches the Sidebar Styles and Formatting Deck and its content panels.
Comment 19 andréb 2015-08-17 04:20:47 UTC
(In reply to V Stuart Foote from comment #18)
> Sorry, no regression here, just progress in the UI which you've not kept up
> with.
> 
> The Styles and Formatting dialog was moved into the Sidebar effective with
> 4.3 release.
> 
> The F11 keyboard shortcut will activate the Styles and Formatting deck in
> the Sidebar
> 
> The Styles and Formatting button on the Formatting menu has been supressed,
> but if used it also launches the Sidebar Styles and Formatting Deck and its
> content panels.

The above comment led me to a little more experimentation, where I discovered the problem.

There is an anomoly : If the side bar is detached and deleted, the styles_and_formatting button in the tool bars does indeed open a detached window with that function.

However, if the side bar is attached and closed, that button, as well as the format menu entry and F11, does nothing.

So I'm reopening this report, adding that additional factor :

If the SIDE BAR IS ATTACHED BUT CLOSED,
the styles_and_formatting function becomes inaccessible via
1) the styles_and_formatting tool bar button,
2) the format menu, and
3) F11

So the user interface should be corrected for this case.
Comment 20 V Stuart Foote 2015-08-17 04:54:10 UTC
OK, that makes sense. And that is a duplicate of bug 83546 -- SIDEBAR: content panels in tray don't open with accelerators when sidebar is enabled but fully hidden.

Maxim M. and I went round on this for bug 91435 -- Writer styles dialog won't open, which was also duped to 83546.

*** This bug has been marked as a duplicate of bug 83546 ***
Comment 21 andréb 2015-08-17 05:27:00 UTC
(In reply to V Stuart Foote from comment #20)

The bug was driving me crazy -- I couldn't figure how to get around it, but almost no-one else was seeing it.
For me, I now detach and close the side bar.  The window that pops up with the style_and_format button is only slightly different from the previous one.
I didn't recognize the description in bug 83546.
Thanks for your feedback in comment 18.