Bug 92825 (Help-Changes-Menu) - [META] Update help for all menu changes
Summary: [META] Update help for all menu changes
Status: NEW
Alias: Help-Changes-Menu
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL: https://wiki.documentfoundation.org/C...
Whiteboard: target:5.1.0 target:5.2.0 target:5.3...
Keywords:
Depends on: 91344 102265 105601 118008 126555 137084 79942 97588 97807 97923 99316 99715 100962 101024 101064 101065 101163 103244 103968 104410 105070 107573 108967 113985 119384 124198 132371 132630 133438 138608 140111 140889
Blocks: Main-Menu Help
  Show dependency treegraph
 
Reported: 2015-07-19 13:47 UTC by Regina Henschel
Modified: 2021-11-16 07:24 UTC (History)
15 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2015-07-19 13:47:18 UTC
There has been a lot of changes in the UI, for example rearranging the menus and a new menu 'Styles' in Writer. None of these changes has been reflected in the help.
Comment 1 Jean-Baptiste Faure 2015-07-19 17:29:18 UTC
The menu Styles in Writer has been added in the master only, the next 5.1 version, not in LO 5.0.

Best regards. JBF
Comment 2 Yousuf Philips (jay) (retired) 2015-09-05 01:25:23 UTC
First patch is in for writer - https://gerrit.libreoffice.org/18288
Comment 3 Commit Notification 2015-10-31 19:52:11 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=83a90f1c85c679b56eb2101f174220c81de1fa46

tdf#92825 Add missing entries in the Edit menu
Comment 4 Commit Notification 2015-11-10 12:13:10 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=886917bcac6656b66f78c84c57cc308299992008

tdf#92825 Rearrange the view menu in writer, calc, and impress
Comment 5 Commit Notification 2016-03-02 21:15:05 UTC
Stanislav Horacek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=17ec8364ffd8f814d9bed18441ae6e8389eb360d

tdf#92825 adjust navigation to indexes and tables of contents
Comment 6 Commit Notification 2016-03-09 16:47:49 UTC
Stanislav Horacek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=eb89b812abd9181f75ebb4f99e89e792065fc934

tdf#92825 adjust path and commands related to footnotes/endnotes
Comment 7 Commit Notification 2016-03-09 21:53:08 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=17d37456a2c3e912a137b7af643de8aa4aa34bbb

tdf#92825 Rearrange Writer's insert menu
Comment 8 Commit Notification 2016-03-25 09:02:42 UTC
Stanislav Horacek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=a367b5ee9d109a611f8684a46b9254de73ec4af8

tdf#92825 adjust menu path to Slide - New Page/Slide
Comment 9 V Stuart Foote 2016-04-15 12:26:08 UTC
*** Bug 99316 has been marked as a duplicate of this bug. ***
Comment 10 V Stuart Foote 2016-04-15 12:41:11 UTC
Hmm, seems this has become a meta tracking both issues and commits resolving them. So, reset bug 99316 from being a dupe to a blocker here.
Comment 11 Commit Notification 2016-04-28 01:30:29 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=32a855a02c55f864af7b2d1a7ebddd55043e297b

tdf#92825 Update Impress’ Master menus
Comment 12 Commit Notification 2016-07-22 15:32:28 UTC
Stanislav Horacek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=d2e8010196b99875138088ec814df71b22554d9d

tdf#92825 adjust menu path for inserting header and footer
Comment 13 Commit Notification 2016-07-22 17:04:57 UTC
Stanislav Horacek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=33e1d32da35c7eae844a798ecbb4df9dd1964769

tdf#92825 adjust menu path for AutoCalculate
Comment 14 Aron Budea 2016-08-19 14:33:01 UTC
*** Bug 101614 has been marked as a duplicate of this bug. ***
Comment 15 Xisco Faulí 2016-09-26 11:07:40 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 16 Ray Holme 2016-09-26 11:55:07 UTC
As far as I (original reporter here) is concerned, it can be marked resolved and closed.
Comment 17 V Stuart Foote 2016-09-26 12:48:15 UTC
Xisco, this is rather a META affecting changes starting at 5.0 and continuing--not sure we can close just yet. 

Also we do need a functional review of entire Help system maybe in time for a 5.3 release--looking at changes to the Menu entries as here is just one facet--Oliver, Sophie?

(In reply to Ray Holme from comment #16)
> As far as I (original reporter here) is concerned, it can be marked resolved
> and closed.

Uh thanks Ray, but that's only for dupe bug 101614
Comment 18 Buovjaga 2017-05-30 13:11:37 UTC
I added this as the URL: https://wiki.documentfoundation.org/Comparison_between_menus_in_LO_4.4.7.2_and_5.1.0.2
Note that it is still incomplete as it only contains Writer and Calc.
Comment 19 Commit Notification 2017-12-19 11:19:26 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=60281fff05e466a706c1d18ec67e38f130a2a26d

tdf#92825 Update Help page for Math File menu
Comment 20 Commit Notification 2017-12-19 11:21:59 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=03d207a1e1b862d4613bdd9d7147b7b1ed046f92&h=libreoffice-6-0

tdf#92825 Update Help page for Math File menu
Comment 21 Commit Notification 2017-12-19 11:22:09 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=c31705b9387dd7c5a94717c7c9ab9ab86f6f5f28&h=libreoffice-6-0

tdf#92825 Update help pages for file menu
Comment 22 Commit Notification 2017-12-19 11:22:18 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=9a20a71a42c6c3113b1e0c9d679565018474d2e4

tdf#92825 Update help pages for file menu
Comment 23 Buovjaga 2019-03-05 19:40:24 UTC
*** Bug 123552 has been marked as a duplicate of this bug. ***