Bug Hunting Session
Bug 92835 - Libreoffice needs an automatic update like Chrome
Summary: Libreoffice needs an automatic update like Chrome
Status: RESOLVED DUPLICATE of bug 68274
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-20 03:37 UTC by Jiggle Billy
Modified: 2016-06-28 19:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiggle Billy 2015-07-20 03:37:07 UTC
LO needs an auto updater that will silently and automatically keep LO updated. 

The great thing about LO is the fact that it improves so quickly and so incrementally and predictably unlike other MS or close source software. 

But having said that there are downsides of frequent updates, it is so annoying to have to download a new LO and install it every month. Take Chrome's or firefox's updaters as an example. Silent, easy painless.


I dont want to see any dialogs, or be asked if i want to download updates. I just want the app to update itself automatically and silently.


This is thankfully not needed on OSX as I have installed LO from the mac app store.


keep up the great work, you guys are fantastic.
Comment 1 m.a.riosv 2015-07-20 21:42:20 UTC
Hi @Jiggle, thanks for reporting.

I think there is a work in progress:

http://nabble.documentfoundation.org/GSoC-Reuse-Mozilla-s-rolling-update-mechanism-for-LibreOffice-Weekly-Report-2-tc4150939.html
Comment 2 Adolfo Jayme 2015-07-21 06:43:53 UTC

*** This bug has been marked as a duplicate of bug 83406 ***
Comment 3 V Stuart Foote 2016-06-28 19:34:31 UTC

*** This bug has been marked as a duplicate of bug 68274 ***