Bug Hunting Session
Bug 92845 - changing value in Tools-Options-LibreOffice Writer-Comparison is not persistent after restart
Summary: changing value in Tools-Options-LibreOffice Writer-Comparison is not persiste...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium normal
Assignee: Gabor Kelemen
URL:
Whiteboard: target:6.4.0 target:6.3.3
Keywords: implementationError, needsDevAdvice
: 71153 (view as bug list)
Depends on:
Blocks: Track-Changes Options-Dialog Help-Changes-Features
  Show dependency treegraph
 
Reported: 2015-07-20 18:29 UTC by J.S.Kim
Modified: 2019-10-03 10:24 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (166.05 KB, image/jpeg)
2015-07-20 18:29 UTC, J.S.Kim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description J.S.Kim 2015-07-20 18:29:57 UTC
Created attachment 117346 [details]
screenshot

I changed a value on [Compare documents] of [Tools-Options-LibreOffice Writer-Comparison] from 'Auto' to 'By character'. But when I restarted the Writer, the value had returned to original state (Auto).
Comment 1 Jean-Baptiste Faure 2015-07-30 05:03:25 UTC
Confirmed for LibreOffice 5.0.1.0+ built at home under Ubuntu 15.04 x86-64 with gcc 5.1.

Setting as NEW.
Comment 2 QA Administrators 2016-09-20 10:21:56 UTC Comment hidden (obsolete)
Comment 3 Jean-Baptiste Faure 2016-09-27 05:03:03 UTC
Still reproducible in LO 5.2.3.0+ and current master, both built at home under Ubuntu 16.04 x86-64.

In fact I am not sure if this behavior is wrong. Could it be meaning that this configuration change is applicable only for the current comparison ?

set status back to unconfirmed.

Best regards. JBF
Comment 4 tommy27 2017-05-11 12:52:26 UTC Comment hidden (obsolete)
Comment 5 Dieter Praas 2017-05-30 16:33:03 UTC
In my view it is a bug, because it is different to all other options, where the settings doesn't change after restarting LibreOffice. Therefore I'd propose to set to NEW. An additional problem is, that there is also no HELP-page (reported in bug 71154)
Comment 6 Yousuf Philips (jay) (retired) 2017-05-30 19:56:07 UTC
So this feature was introduced in 3.6 and acts this same way from then, so lets see if our veterans (Cor, Regina, Maxim) can give their input on how this is supposed to work, and lets get a help page added about this feature.
Comment 7 Cor Nouws 2017-08-11 21:00:00 UTC
I thinks it's a bug
Comment 8 Dieter Praas 2017-09-13 16:27:48 UTC
Duplicate of bug 71153?
Comment 9 Timur 2017-09-13 17:26:18 UTC
(In reply to Dieter Praas from comment #8)
> Duplicate of bug 71153?

Looks so.

*** This bug has been marked as a duplicate of bug 71153 ***
Comment 10 Yousuf Philips (jay) (retired) 2017-09-14 13:06:58 UTC
This bug has more input/work in it, so lets keep this open and close the older one as a duplicate.
Comment 11 Yousuf Philips (jay) (retired) 2017-09-14 13:07:08 UTC
*** Bug 71153 has been marked as a duplicate of this bug. ***
Comment 12 QA Administrators 2018-09-15 03:09:47 UTC Comment hidden (obsolete)
Comment 13 Jean-Baptiste Faure 2018-09-15 20:52:28 UTC
Still reproducible with LibreOffice 6.1.2.0.0+ built at home under Ubuntu 18.04
x86-64.

Best regards. JBF
Comment 14 Gabor Kelemen 2019-09-28 22:50:25 UTC
Proposed patch: https://gerrit.libreoffice.org/#/c/79807/
Comment 15 Commit Notification 2019-10-01 09:31:47 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/32e781d268e59397016f7243fc92d5408577d593

tdf#92845 Save Writer - Comparison settings properly

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2019-10-02 09:23:07 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/7a7ce545697446084deaa0d9aa0feffc34dbad3d

tdf#92845 Save Writer - Comparison settings properly

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.