Download it now!
Bug 92864 - Autosave moving the view within a document
Summary: Autosave moving the view within a document
Status: RESOLVED DUPLICATE of bug 41063
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-22 03:38 UTC by Stephen Meatheringham
Modified: 2015-07-24 20:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Meatheringham 2015-07-22 03:38:16 UTC
Hi

I have found what is, IMO, a bug with LibreOffice Writer.

My version is 4.4.2.2 and Build ID 40m0(Build:2). My O/S is 64-bit Ubuntu 15.04, Linux kernel 3.19.0-21-generic.  I cannot tell if the problem occurs with other versions of LibreOffice and/or on other O/S'es.

The problem is pretty easy to describe and completely reproducible on my system.

Let’s say I am editing a large document (it can be ODT or Word format). I make some changes, and scroll to another part of that document (for example, 50+ pages away) preparing to make an edit, but not having clicked in the new location. Then Writer decides it is time to autosave before I can click to set the new insertion point. It autosaves and sends my view in the document back to where the insertion point is, some 50+ pages away from the point I have so carefully scrolled to.

I do not believe that autosave should do this, and I certainly cannot see any way to mitigate the problem. Increasing the autosave time will lessen the frequency but that is a trade-off against possible loss of more work if Writer should crash/hang and be unable to recover.

Your thoughts?

regards
Stephen Meatheringham
Canberra, Australia
Comment 1 Jean-Baptiste Faure 2015-07-24 20:12:39 UTC
Problem already reported in bug 92365 which is a duplicate of bug 41063.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 41063 ***