Bug 92951 - Slide pane and Page pane can no longer be moved from left side docking
Summary: Slide pane and Page pane can no longer be moved from left side docking
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
5.0.0.4 rc
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:5.2.0 target:5.1.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2015-07-27 08:33 UTC by Bastián Díaz
Modified: 2016-10-25 19:02 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bastián Díaz 2015-07-27 08:33:47 UTC
Testing the new version of LibreOffice 5, it is no longer possible to use the sidebar to the left side of the screen in Impress/Draw, as the slide/pages panel is locked. It is even possible, to completely removing the slide panel, but in my custom setup use the slide panel in the right side of the screen.
Since version 4.4.4.3 a bug that prevented use the sidebar in left side of the screen is fixed, and for some users this configuration is the most convenient and logical for our workflow, and is expected to be used in all LibreOffice applications.

Thank You
Comment 1 V Stuart Foote 2015-07-27 15:02:29 UTC
> Testing the new version of LibreOffice 5, it is no longer possible to use
> the sidebar to the left side of the screen in Impress/Draw

This is not correct. The Sidebar can be undocked and then dragged to dock at left upper edge in Draw or Impress, above the Pages pane or Slide pane respective.

However, confirming, that presently (for the 5.0.0rc's) the "Page pane" or "Slide pane" can no longer be dragged off the left edge. 

Unable to locate a control or Expert configuration stanza that would allow the Page/Slide pane to be movable.
Comment 2 raal 2015-10-09 11:55:43 UTC
This seems to have begun at the below commit.
Adding Cc: to caolanm@redhat.com ; Could you possibly take a look at this
one? Thanks

bibisect-win32-5.0:
ee40298f9f27cc9e5a1dc06566b359332a80c66a is the first bad commit
commit ee40298f9f27cc9e5a1dc06566b359332a80c66a
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri May 15 04:38:48 2015 -0500

    source sha:def217464a2ac4a5d140725ba0e1247ff85fbd2e

    source sha:def217464a2ac4a5d140725ba0e1247ff85fbd2e
    source sha:2f25dc9644397ff4fc5e9586106aaca32950b596
    source sha:780457b1595158ac37c3217528c8f087d9fc16c3
    source sha:3aab42022bfdcad518f1d4ae4c6380745c0edf5f
    source sha:29bb99c5e735aa1d23e15816bb44f56e79e9bbc7

:040000 040000 1b45d3b4ff01b8292cd5e5e7347558502f6350ae 7e9e34f02e8bd268f38be4ce010e9814c5d2ef37 M      instdir


author	Caolán McNamara <caolanm@redhat.com>	2014-12-22 15:07:13 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2014-12-22 15:11:50 (GMT)
commit	2f25dc9644397ff4fc5e9586106aaca32950b596 (patch)
de-resource FLT_LEFT_PANE_[DRAW|IMPRESS]_DOCKING_WINDOW
Comment 3 Robinson Tryon (qubit) 2015-12-13 11:13:27 UTC Comment hidden (obsolete)
Comment 4 haevalencia 2016-04-14 07:48:00 UTC
This bug is still present in 5.1.2.1.0 on fedora 23. Please, since version 5 which I can't move or undock the page pane.
Comment 5 Commit Notification 2016-05-11 12:00:11 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7200965a31cafed1d37de9946b417ceac2e850e0

Resolves: tdf#92951 make PaneDockingWindow dockable again

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2016-05-11 13:40:39 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a9277eabc8dfefba1a255097ec212745941b3fc9&h=libreoffice-5-1

Resolves: tdf#92951 make PaneDockingWindow dockable again

It will be available in 5.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Bastián Díaz 2016-05-12 01:42:37 UTC
Thank you