Bug 93004 - New Theme Issues on Windows Installer
Summary: New Theme Issues on Windows Installer
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
5.0.0.4 rc
Hardware: Other Windows (All)
: medium minor
Assignee: Christian Lohmaier
URL:
Whiteboard: target:5.1.0 target:5.0.0
Keywords:
: 99151 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-29 16:38 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-10-25 19:17 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Windows Installer visual problems (30.11 KB, image/png)
2015-07-29 16:38 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-07-29 16:38:52 UTC
Created attachment 117517 [details]
Windows Installer visual problems

While trying out the latest daily build on windows, i noticed two issues with the new 5.0 visual design in the installer.

1) In the initial parts of the wizard, the visual design is in a column on the left and there are 2 shades of gray above the green box, as there is a line separator going through it. As this doesnt also happen at the bottom, i would suggest that the top be similar to the bottom

2) In other pats of the wizard, the visual design is in a row at the top and the gray left portion of it appears above below black text, which cause the text to be difficult to read. Also the right bottom corner of row is missing gray pixels under the very dark portion of the green square.
Comment 1 tommy27 2015-07-29 19:45:37 UTC
confirmed under Win8.1 x64 with LibO 5.1.0.0.alpha1+
Build ID: 62e2fae93e8894f73560a30ae1e752cbd4c001ad
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-07-29_04:40:44
Locale: en-US (it_IT)
Comment 2 Christian Lohmaier 2015-07-30 21:59:06 UTC
the left part is intentional - the exceeding grey shadow above the image can also be found on the (empty, no documents yet) startcenter.

The bottom-right corner of the banner (the thing at the top is an artifact of the dialog/the line below the image, not in the image itself). But I'll replace that by a smaller version, to not have the text on the grey background.
Comment 3 Commit Notification 2015-07-30 22:12:22 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=303b7758e90e11aedef95e4ab51b74398cd2ce0a

tdf#93004 msi banner: avoid overlapping text with grey background

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2015-07-30 23:49:34 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-5-0-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1c035f08d3f1556642918ef2c6d3758c4b9618c7&h=libreoffice-5-0-0

tdf#93004 msi banner: avoid overlapping text with grey background

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2015-07-30 23:49:41 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=67be20f2d09e299cd112428faec897b1da1623b7&h=libreoffice-5-0

tdf#93004 msi banner: avoid overlapping text with grey background

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Yousuf Philips (jay) (retired) 2015-07-31 13:55:38 UTC
(In reply to Christian Lohmaier from comment #2)
> the left part is intentional - the exceeding grey shadow above the image can
> also be found on the (empty, no documents yet) startcenter.

Yes i am aware that it looks like that in the start center, where there is blank space on all four sides, but in this case where there is only blank space above and below, it doesnt look good.
Comment 7 Adolfo Jayme 2015-07-31 23:55:36 UTC
> Yes i am aware that it looks like that in the start center, where there is
> blank space on all four sides, but in this case where there is only blank
> space above and below, it doesnt look good.

I agree that the graphic assets are sloppily done. Harsh colors, super-imposing obstructing patterns everywhere, a huge number that is not even part of our brand elements… But then again, this is what happens when somebody commissions work privately, without getting *your own* designers’ input. Congrats, TDF! </sarcasm>
Comment 8 tommy27 2015-08-01 04:51:21 UTC
what about this page? 
https://wiki.documentfoundation.org/Design/Whiteboards/5.0_Branding

I thought the new LibO 5.0 had to come out from one of these proposals...
Comment 9 Adolfo Jayme 2016-04-09 22:11:14 UTC
*** Bug 99151 has been marked as a duplicate of this bug. ***