Download it now!
Bug 93039 - Improve support for importing and editing PDF files in all modules of LibreOffice
Summary: Improve support for importing and editing PDF files in all modules of LibreOf...
Status: RESOLVED DUPLICATE of bug 32249
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.4 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-30 23:56 UTC by M-Rick
Modified: 2017-01-13 09:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Open>File : PDF opens with Draw (46.24 KB, image/png)
2015-08-01 12:18 UTC, M-Rick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description M-Rick 2015-07-30 23:56:19 UTC
It doesn't seem to import PDF documents inside a Writer document.
It is a really missing feature  because I need, in my case, to insert PDF documents in some contracts.

Calc doesn't handle PDF documents at all.

Draw can insert PDF, but it will crash with some complex PDF drawings…

Impress can insert PDF nicely, but will resize them by default, and it is needed to edit them with an unintuitive feature …

Database doesn't handle PDF documents at all in its forms…


To make it simple, PDF support in all modules should be native and must be enhanced when existing.
Comment 1 Alex Thurgood 2015-07-31 07:54:43 UTC
@M-Rick : Writer already opens some PDF documents 

Cmd-O, scroll down the file type to Portable Document Format Writer (pdf)
Comment 2 Alex Thurgood 2015-07-31 07:55:51 UTC
At best this is an enhancement request, but title needs to be reworded.
Comment 3 M-Rick 2015-08-01 11:54:26 UTC
(In reply to Alex Thurgood from comment #1)
> @M-Rick : Writer already opens some PDF documents 
> 
> Cmd-O, scroll down the file type to Portable Document Format Writer (pdf)

For me it doesn't or it's unintuitive.

If I drag a simple invoice over a Writer document, a new window opens asking me if I want to link or DDE (? what is the meaning ??) whathever I choose, I don't get my single page PDF invoice inserted.
Comment 4 M-Rick 2015-08-01 12:18:30 UTC
Created attachment 117572 [details]
Open>File : PDF opens with Draw

PDF are open with Draw, but they are exploded … So

- Writer will not open them
- The integrity is not kept since the file is exploded …
Comment 5 m.a.riosv 2017-01-13 09:31:54 UTC

*** This bug has been marked as a duplicate of bug 32249 ***