Bug 93040 - Text orientation in table in Writer should be more advanced like in Calc.
Summary: Text orientation in table in Writer should be more advanced like in Calc.
Status: RESOLVED DUPLICATE of bug 60006
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-31 04:42 UTC by Ramil
Modified: 2017-12-12 17:58 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Cool text orientation in Calc (54.06 KB, image/png)
2015-07-31 04:42 UTC, Ramil
Details
Poor text orientation in Writer (81.00 KB, image/png)
2015-07-31 04:43 UTC, Ramil
Details
vertical text with table properties for one cell (63.54 KB, image/png)
2015-08-01 01:28 UTC, Ramil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ramil 2015-07-31 04:42:57 UTC
Created attachment 117548 [details]
Cool text orientation in Calc

Text orientation options in table in Writer is poor. We can use only horizontal and vertical orientation (270 degrees). But I know many people who need more. At least need 0, 90 and 270 degrees, not only 0 and 270.

In addition to Calc it's already very convenient, you can choose any angle.

Please make similar text orientation interface in table in Writer and Calc.


P.S.: See screenshots in attachments.
Comment 1 Ramil 2015-07-31 04:43:36 UTC
Created attachment 117549 [details]
Poor text orientation in Writer
Comment 2 Jean-Baptiste Faure 2015-07-31 15:10:29 UTC
What is your LibreOffice version ?
Did you try Format > Character ? I see 3 possible orientations, 0, 90 and 270 degrees. Available since LO 4.0, at least.

Best regards. JBF
Comment 3 Ramil 2015-07-31 15:26:26 UTC
(In reply to Jean-Baptiste Faure from comment #2)
 		
Yes I tried that way and it led me to create 5 reports:
https://bugs.documentfoundation.org/show_bug.cgi?id=91957
https://bugs.documentfoundation.org/show_bug.cgi?id=91959
https://bugs.documentfoundation.org/show_bug.cgi?id=91961
https://bugs.documentfoundation.org/show_bug.cgi?id=91962
https://bugs.documentfoundation.org/show_bug.cgi?id=92330

It mean that work with vertical text using Format -> Character is not useful, it is annoying.

Now I understand that it is better to use Format -> Table... But need to add functionality in this version. After that, all previous requests will not be relevant.
Comment 4 Jean-Baptiste Faure 2015-07-31 17:52:36 UTC
(In reply to ⚡ Thunde® ⚡ from comment #3)
> [...]
> Now I understand that it is better to use Format -> Table... But need to add
> functionality in this version. After that, all previous requests will not be
> relevant.

Why Format > Table ?
If you set the text to vertical in the table format, that will be applicable to all cells of the table. How do you do to have vertical text in some cells only?

There is a more general purpose way to add text vertically written in a text document, use text boxes (there is an icon in the standard toolbar of LO 5). Using text boxes allows you to solve the problem of the text flow, mixing horizontal and vertical text in the same page. You do not have this problem in Calc where you can't mix horizontal and vertical text in the same cell. From that point of view, each cell in a spreadsheet is a text box.

Best regards. JBF
Comment 5 Ramil 2015-08-01 01:23:40 UTC
(In reply to Jean-Baptiste Faure from comment #4)
> Why Format > Table ?
> If you set the text to vertical in the table format, that will be applicable
> to all cells of the table. How do you do to have vertical text in some cells
> only?

It is not so. I just tried using the table properties for a single cell and it worked. See the attachment.



I will try text boxes in LO 5, thanks!
Comment 6 Ramil 2015-08-01 01:28:28 UTC
Created attachment 117569 [details]
vertical text with table properties for one cell
Comment 7 Xisco Faulí 2016-09-10 15:03:45 UTC Comment hidden (obsolete)
Comment 8 Xisco Faulí 2016-10-10 11:33:07 UTC Comment hidden (obsolete)
Comment 9 Dmitry 2017-12-12 17:54:36 UTC

*** This bug has been marked as a duplicate of bug 60006 ***