Bug 93057 - LO 5 does use the existing user profile LibreOffice/4/user, but this is not mentioned in the release notes
Summary: LO 5 does use the existing user profile LibreOffice/4/user, but this is not m...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.0.0.4 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
: 90747 93266 93882 98234 106243 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-08-01 08:24 UTC by Peter Chastain
Modified: 2017-02-28 22:54 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Chastain 2015-08-01 08:24:33 UTC
I am having the problem described in Bug 78776, i.e., when I invoke F1 Help in Base, Write, Calc, Draw, etc. (LO 5.0.0 RC4), the built-in Help that I downloaded is not used. Someone in Ask suggested that I remove my user profile so that LO could re-create it. Looking at https://wiki.documentfoundation.org/Documentation/UserProfile#For_Windows_users: I see that my user profile should be C:\Users\<username="">\AppData\Roaming\LibreOffice\3\user. If the "3" in that path stands for LO version 3, I would expect my profile path to be "...\LibreOffice\5\user", but instead it is "...\LibreOffice\4\user". If I rename it and re-start LO, it is again created with the number 4, and I still get the online version of help.
Comment 1 Adolfo Jayme 2015-08-01 11:27:16 UTC
This is not a bug; it was made on purpose in order to minimize profile migration issues. http://cgit.freedesktop.org/libreoffice/core/commit/?id=468aaa1bcf96c86c4a33b5dcd0aabb41e14b042d

*** This bug has been marked as a duplicate of bug 90747 ***
Comment 2 Cor Nouws 2015-08-01 11:28:27 UTC
Hi Peter,

Thanks for taking trouble to report this.
This change is intentional, to make it easier to continue to use all the user settings. (Short summary of a topic with some complicated corner cases.)
I see it is not mentioned in the release notes..
So I change subject and some more of the report. Hope you agree with that.
Cheers - Cor
Comment 3 Peter Chastain 2015-08-01 21:00:53 UTC
@Adolfo Jayme & @Cor Nouws, I apprecate your investigating and explaining. Yes, I agree with the change in topic and resolution. Thanks!
Comment 4 Cor Nouws 2015-08-02 15:24:57 UTC
Added some info here
 https://wiki.documentfoundation.org/ReleaseNotes/5.0#User_settings_-_location_of_the_user_profile

Feel free to improve.
Thanks,
Cor
Comment 5 Cor Nouws 2015-08-08 12:44:24 UTC
*** Bug 93266 has been marked as a duplicate of this bug. ***
Comment 6 V Stuart Foote 2015-08-10 14:45:44 UTC
Added 90747 as a see also, the fix was just for the release notes
Comment 7 Cor Nouws 2015-09-03 09:40:46 UTC
*** Bug 93882 has been marked as a duplicate of this bug. ***
Comment 8 Cor Nouws 2016-02-27 20:55:14 UTC
*** Bug 98234 has been marked as a duplicate of this bug. ***
Comment 9 Colin 2016-02-27 23:06:56 UTC
It seems a bit disingenuous to claim migration issues which sounds more like a specious excuse. The reality is that installation of LO5 uninstalls and completely removes all traces of LO4 from the users' systems so, if LO5 installation simply renames the directory "5" and of course updates the associated registry entries, a specious excuse wouldn't even be necessary. Or would you disagree?
Note: it doesn't quite remove all traces of the previous LO4 installation - somebody forgot to either remove the task bar shortcut from win 10 or edit it so it points to the new software which, funnily enough, is now found in LO5.
Should I report that as a bug or was that simply another new and undocumented feature?
Comment 10 V Stuart Foote 2016-02-27 23:48:50 UTC
(In reply to Colin from comment #9)

It was an absolutely defensible ESC decision to retain the user profile as LibreOffice\4 for the 5 release, mainly because of issues with handling external extensions recorded in berklydb into the user profile that folks had complained about for the 3.x to 4.x release transition. 

Decision was no real need to sync the folder/directory name to the release--and so simplified the "continuation" of existing profiles.  

Although recommendation remains to backup customizations and dump profile for a clean install.

=-ref-= 
ESC minutes 
2015-03-15
http://nabble.documentfoundation.org/minutes-of-ESC-call-td4142383.html

2015-04-02
http://nabble.documentfoundation.org/Minutes-of-ESC-call-2015-04-02-td4145334.html


> Note: it doesn't quite remove all traces of the previous LO4 installation -
> somebody forgot to either remove the task bar shortcut from win 10 or edit
> it so it points to the new software which, funnily enough, is now found in
> LO5.
> Should I report that as a bug or was that simply another new and
> undocumented feature?

No, on Windows if you've pinned a task bar or Start Menu shortcut and then uninstall the program it is your issue to clean them up--same for other "orphaned" desktop shortcuts you might create that aren't under program installer control.
Comment 11 V Stuart Foote 2017-02-28 22:49:17 UTC
*** Bug 106243 has been marked as a duplicate of this bug. ***
Comment 12 V Stuart Foote 2017-02-28 22:51:24 UTC
*** Bug 90747 has been marked as a duplicate of this bug. ***