Bug 93074 - [Impress] Wrong import of colors in table from Powerpoint .pptx
Summary: [Impress] Wrong import of colors in table from Powerpoint .pptx
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pptx
Depends on:
Blocks: Document-Colors-Palette PPTX
  Show dependency treegraph
 
Reported: 2015-08-02 10:06 UTC by Gerry
Modified: 2018-02-11 15:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Powerpoint file with table (70.48 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-08-02 10:06 UTC, Gerry
Details
Screenshot of file in Powerpoint 2010 (93.12 KB, image/png)
2015-08-02 10:08 UTC, Gerry
Details
Screenshot of file in LO 5.0 (Windows) (120.71 KB, image/png)
2015-08-02 10:09 UTC, Gerry
Details
Screenshot of file in LO 4.4 (Ubuntu) (91.23 KB, image/png)
2015-08-02 10:10 UTC, Gerry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2015-08-02 10:06:43 UTC
Created attachment 117594 [details]
Test Powerpoint file with table

LibreOffice Impress chooses completely wrong colors of table cells and font color when importing attached .pptx file. The file has been created with Powerpoint 2010.

The 2nd attachment shows a screenshot of the file in Powerpoint 2010.
The 3nd attachment shows a screenshot of the file in LibreOffice 5.0.0.5.
The 4th attachment shows a screenshot of the file in LibreOffice 4.4.2.2.

I tested the problem in two LO versions and it is the same in both:

Version: 4.4.2.2
Build-ID: 40m0(Build:2)
Gebietsschema: de_DE
Ubuntu 15.04

Version: 5.0.0.5 (x64)
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: en-US (en_US)
Windows 7 professional service pack 1
Comment 1 Gerry 2015-08-02 10:08:35 UTC
Created attachment 117595 [details]
Screenshot of file in Powerpoint 2010
Comment 2 Gerry 2015-08-02 10:09:18 UTC
Created attachment 117596 [details]
Screenshot of file in LO 5.0 (Windows)
Comment 3 Gerry 2015-08-02 10:10:05 UTC
Created attachment 117597 [details]
Screenshot of file in LO 4.4 (Ubuntu)
Comment 4 Jacques Guilleron 2015-08-02 12:20:04 UTC
Hi Gerry,

I reproduce with 
LO 5.1.0.0.alpha1+ Build ID: 8cfdd81b70ef37927b40497ffd10034f28335034
TinderBox: Win-x86@39, Branch:master, Time: 2015-07-24_02:47:18
Also with
LO 3.5.3.2 Build ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80
& Windows 7 Home Premium.
So, probably inherited from OOo.

Thanks for the report.
Comment 5 Buovjaga 2015-08-02 12:24:29 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 902255645328efde34ddf62227c8278e8dd61ff0
TinderBox: Win-x86@39, Branch:master, Time: 2015-07-30_03:52:07
Locale: en-US (fi_FI)
Comment 6 m.a.riosv 2015-08-02 13:37:20 UTC
Hi @Gerry, thanks for reporting.

Green colors a showed in LibreOffice with all versions since:
Win7x64
LibreOffice 3.3.4 OOO330m19 (Build:401)
up to 
Version: 5.0.0.4 (x64) Build ID: cf112dc905650fb985306a7a03d2fe3fcc6c978f
and with AOo 4.1.1

But greens are not showed with google docs.
Neither with the Microsoft PP viewer.
Comment 7 QA Administrators 2016-11-08 11:25:29 UTC Comment hidden (obsolete)
Comment 8 Jacques Guilleron 2016-11-08 14:24:20 UTC
Hi all,

Works for me since 5.2.0.0.beta2
Build ID: a83fc06803e11f27e95c809fdfacbbd0377ff7d0
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR)

Jacques
Comment 9 Gerry 2016-11-09 06:36:03 UTC
To be sure, I reset this bug to "NEW".

I tested with LibreOffice 5.1.4 and the bug is still present. Jacques has tested LO 5.2 and the bug seemed to be solved on his system.

Can anyone else verify that the bug is solved in the most recent version?


Version: 5.1.4.2
Build-ID: 1:5.1.4-0ubuntu1
CPU-Threads: 4; BS-Version: Linux 4.4; UI-Render: Standard; 
Gebietsschema: en-US (de_DE.UTF-8)
Comment 10 Gerry 2017-08-29 18:39:00 UTC
Hi, 

I checked this bug with a recent LibreOffice version on Ubuntu 16.04. and it works for me. The screenshot looks exactly like in Powerpoint 2010.

Can anyone else test it, too, and then close it as WORKSFORME?

Version: 5.4.0.3
Build ID: 1:5.4.0~rc3-0ubuntu0.16.04.1~lo1
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: de-DE (de_DE.UTF-8); Calc: single
Comment 11 Gerry 2018-02-11 15:00:29 UTC
WORKSFORME in Version: 6.0.1.1
Build ID: 1:6.0.1~rc1-0ubuntu0.16.04.1~lo1
CPU threads: 4; OS: Linux 4.4; UI render: GL; VCL: gtk2; 
Locale: de-DE (de_DE.UTF-8)