Bug 93145 - Icon themes are not self-contained in 5.0 any more (was: the icon on Sidebar and Bottom right corner cannot display on Ubuntu 14.04)
Summary: Icon themes are not self-contained in 5.0 any more (was: the icon on Sidebar ...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 93274 93360 93378 93448 93481 93658 93677 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-08-05 14:17 UTC by Deng Kai
Modified: 2016-03-29 23:03 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
the icon on Sidebar and Bottom right corner cannot display on Ubuntu 14.04 (172.32 KB, image/png)
2015-08-05 14:17 UTC, Deng Kai
Details
Icon is missing (93.38 KB, image/png)
2015-08-13 17:36 UTC, Gaël Rousseau
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Deng Kai 2015-08-05 14:17:08 UTC
Created attachment 117675 [details]
the icon on Sidebar and Bottom right corner cannot display on Ubuntu 14.04

the icon on Sidebar and Bottom right corner cannot display on Ubuntu 14.04
Desktop enviromment:Unity
Comment 1 Adolfo Jayme 2015-08-09 15:32:36 UTC
Thank you for your bug report.
Comment 2 Björn Michaelsen 2015-08-09 22:40:41 UTC
For some reason, on 5.0 our icon themes are not self contained anymore: This causes missing icons and crashes for e.g. both human and sifr themes if at least galaxy isnt installed as the ultimate fallback.
Comment 3 Maxim Monastirsky 2015-08-11 19:27:24 UTC
*** Bug 93360 has been marked as a duplicate of this bug. ***
Comment 4 Maxim Monastirsky 2015-08-12 10:16:23 UTC
*** Bug 93378 has been marked as a duplicate of this bug. ***
Comment 5 Gaël Rousseau 2015-08-13 17:36:14 UTC
Created attachment 117898 [details]
Icon is missing

Almost the same problem here (Ubuntu 14.04 LTS x86) but just the first icon in the sidebar is missing.
Comment 6 Audran Moulard 2015-08-15 14:30:41 UTC
Same problem
Comment 7 Maxim Monastirsky 2015-08-15 19:16:50 UTC
*** Bug 93274 has been marked as a duplicate of this bug. ***
Comment 8 Maxim Monastirsky 2015-08-15 20:54:39 UTC
Well, it was an intentional change made in:

commit b6bdc6771199b7b05d4f9840b66ebce3bb61d7db
Author: Jan Holesovsky <kendy@collabora.com>
Date:   Sun Nov 23 03:07:44 2014 +0100

    icons: Package only the icons that are in the theme.
    
    The fallback is now implemented directly in vcl, no need to waste space any
    more.
    
    Change-Id: Ia027fda5e92d2bac7369139f3277d73b0521bef2


@kendy: I guess we can close this one as NOTOURBUG, and let downstream fix their packaging?
Comment 9 Maxim Monastirsky 2015-08-17 11:48:27 UTC
*** Bug 93481 has been marked as a duplicate of this bug. ***
Comment 10 Maxim Monastirsky 2015-08-22 22:42:47 UTC
*** Bug 93448 has been marked as a duplicate of this bug. ***
Comment 11 Maxim Monastirsky 2015-08-25 17:45:06 UTC
*** Bug 93658 has been marked as a duplicate of this bug. ***
Comment 12 Maxim Monastirsky 2015-08-26 12:59:05 UTC
*** Bug 93677 has been marked as a duplicate of this bug. ***
Comment 13 Yousuf Philips (jay) (retired) 2015-10-30 14:12:04 UTC
During a build, Kendy mentioned that icons missing in tango that are in industrial get added to the tango zip file, so this should also happen with human.

(In reply to Maxim Monastirsky from comment #8)
> @kendy: I guess we can close this one as NOTOURBUG, and let downstream fix
> their packaging?

About downstream, package maintainers have been informed that icon theme dependencies need to added to icon theme packages, and galaxy is a mandatory installation for LO.

https://lists.debian.org/debian-openoffice/2015/09/msg00343.html
Comment 14 Amr Ibrahim 2015-11-28 13:39:38 UTC
I fixed this in LibreOffice 5 by explicitly installing libreoffice-gtk3 in Ubuntu 14.04 amd64. I think it has something to do with VCL and GTK+3 integration. I have galaxy installed too.

I can see all icons in human and sifr themes now.
Comment 15 Björn Michaelsen 2016-03-29 23:03:04 UTC
Closing this as WONTFIX: Downstream packaging has been adapted, and we (upstream) now can declare darkness as the new standard and claim this is by design.