Bug Hunting Session
Bug 93157 - Writer should support all font styles not only Roman, Italic, Bold, Bold Italic
Summary: Writer should support all font styles not only Roman, Italic, Bold, Bold Italic
Status: RESOLVED DUPLICATE of bug 35538
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-05 20:27 UTC by DeepFlight5
Modified: 2018-01-05 10:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DeepFlight5 2015-08-05 20:27:50 UTC
For serious typesetting Writer should support all font styles not only Roman, Italic, Bold, Bold Italic. Many fonts come today with many extra styles like Condensed (in different styles), Small Caps (in different styles), Display (in different styles), Text (in different styles), Ornaments (in different styles). But Writer is limited to Roman, Italic, Bold, Bold Italic only. Sometimes, when a font contains many sub-styles, Roman does not show Roman but some random style (like SmallCaps) in the Writer document. The font selection field in Writer should contain not only the font name but also a way to select all sub-styles. If an installed font contains 100 sub-styles I'd like to use any style I want.
Comment 1 Joel Madero 2015-08-05 20:42:31 UTC
Please attach a document with all these different styles that you say are not supported. Marking as NEEDINFO - once you attach a document please set to UNCONFIRMED. Thanks
Comment 2 Christian Lohmaier 2015-09-01 14:47:21 UTC
duplicate - note that for graphite enabled fonts, you can use the font's features by appending the options after the fontname (i.e. "Linux Libertine G:smcp=1" for enabling small caps variant -- more details here http://numbertext.org/linux/fontfeatures.pdf )

For opentype one, this IIRC doesn't work → setting duplicate.

*** This bug has been marked as a duplicate of bug 87288 ***
Comment 3 Thomas Linard 2018-01-05 10:16:47 UTC

*** This bug has been marked as a duplicate of bug 35538 ***