Bug 93175 - Borders for selected Navigator list items misaligned at times.
Summary: Borders for selected Navigator list items misaligned at times.
Status: RESOLVED DUPLICATE of bug 49634
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: RenderContext
  Show dependency treegraph
 
Reported: 2015-08-06 05:00 UTC by Michael Heyns
Modified: 2017-10-15 18:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Border of list item misaligned (3.09 MB, image/jpeg)
2015-08-06 05:00 UTC, Michael Heyns
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Heyns 2015-08-06 05:00:06 UTC
Created attachment 117698 [details]
Border of list item misaligned

This happens randomly when selecting an item in the navigator list.
Unable to take a screenshot so I took a picture instead.

LibreOffice 5.0.0 on Arch Linux.
Comment 1 Buovjaga 2015-09-01 17:34:18 UTC
Confirmed.
Problem is not in 4.3.0.1

Win 7 Pro 64-bit, Version: 5.0.1.2 (32-bit)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: fi-FI (fi_FI)
Comment 2 raal 2015-10-13 12:12:56 UTC
This seems to have begun at the below commit.
Adding Cc: to tomaz.vajngerl@collabora.co.uk ; Could you possibly take a look at this
one? Thanks

~/bibisect-win32-5.0: 862786c7782f9dce209c5e1fadf071cfcd0db171 is the first bad commit
commit 862786c7782f9dce209c5e1fadf071cfcd0db171
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Jun 4 03:08:33 2015 -0500

    source 25a0bd7b909fb8c87387d1413060f6c4ba5a51bd

    source 25a0bd7b909fb8c87387d1413060f6c4ba5a51bd

:040000 040000 873f5b29fd60cb09bf44d5e88555c640262f3177 e6bbd4f1312dad822b345047bde2d9b754d105b2 M      instdir

author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2015-05-11 00:41:13 (GMT)
committer	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2015-05-11 01:03:29 (GMT)
commit 25a0bd7b909fb8c87387d1413060f6c4ba5a51bd (patch)
refactor TreeListBox to use RenderContext
Comment 3 Robinson Tryon (qubit) 2015-12-13 11:13:04 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2016-09-26 15:09:39 UTC
Adding Cc: to Tomaž Vajngerl
Comment 5 Xisco Faulí 2017-01-20 10:39:46 UTC
*** Bug 105434 has been marked as a duplicate of this bug. ***
Comment 6 Jim Raykowski 2017-10-15 18:20:31 UTC

*** This bug has been marked as a duplicate of bug 49634 ***