Bug Hunting Session
Bug 93194 - Initial rendering contains errors but is fixed by re-sizing bigger or smaller
Summary: Initial rendering contains errors but is fixed by re-sizing bigger or smaller
Status: RESOLVED DUPLICATE of bug 93076
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-06 12:22 UTC by Aprax
Modified: 2016-02-13 12:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
when first opened, with errors (83.36 KB, image/png)
2015-08-06 12:22 UTC, Aprax
Details
correct rendering after resizing (92.32 KB, image/png)
2015-08-06 12:23 UTC, Aprax
Details
bad rendering v 5.1.0.3 calc (80.81 KB, image/png)
2016-02-13 12:34 UTC, Aprax
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aprax 2015-08-06 12:22:48 UTC
Created attachment 117711 [details]
when first opened, with errors

When the first ods is first opened, the rendering contains errors, see the screenshot.
By simply re-sizing, i.e. grab an edge and drag it to force re-rendering and everything is OK as per second screenshot.
If the first ods is still open when a second ods is opened, the second ods is rendered correctly.
My guess is that the rendering code is incomplete until the re-sizing, but once loaded, is available to all other ods.

Not a huge deal once someone finds the 'temporary fix' but the bug could scare some non-technical users.

Calc loads much faster now with V 5, which is nice, but this may contribute to the bug.

W7Pro-SP1 64bit.
Comment 1 Aprax 2015-08-06 12:23:42 UTC
Created attachment 117712 [details]
correct rendering after resizing
Comment 2 Cor Nouws 2015-08-06 13:10:28 UTC
Thanks for reporting Aprax,

I cannot confirm the problem (maybe others can). But I do add a link to another rendering issue. There is some work ongoing in this area, so I'm of good hope that it will be fixed soon..
Ciao - Cor
Comment 3 Aprax 2015-08-26 08:53:23 UTC
Rendering is a big issue in 5.0.0.5 in both calc and writer, with writer being a huge issue. I'm going to revert to 4.4.6 until this issue gets fixed.

It seems that if I open either an .odt or .ods that I have to wait for about 20 minutes for rendering to 'settle down'. It's as though 'stuff' required for stable rendering takes that long to 'load' and the documents to become stable, i.e. not 'jumping around'.

I added a Tag of 'Rendering' to this bug.
Comment 4 Hendrik Woltersdorf 2015-09-02 19:29:40 UTC
The issue exists on Linux too; openSUSE-Tumbleweed, Version 5.0.1.2.
Found on KDE and Xfce.

The downstream maintainer found a workaround:
Start LO with:
"SAL_USE_VCLPLUGIN=gen loffice"

In Calc there is another issue - possibly connected to this one:

When I type some numbers into a cell they "vanish" when I press "Enter"; that means, they get invisible, but are still there.
With the gen-renderer I can see these "vanished" numbers again.

Downstream Link:
https://bugzilla.suse.com/show_bug.cgi?id=941035
Comment 5 Maxim Monastirsky 2015-09-02 19:38:23 UTC
(In reply to Hendrik Woltersdorf from comment #4)
> The issue exists on Linux too; openSUSE-Tumbleweed, Version 5.0.1.2.
> Found on KDE and Xfce.
Looking at the screenshot at suse bugzilla, this is *not* the same bug as this one. Instead you should look at Bug 93373.

> The downstream maintainer found a workaround:
> Start LO with:
> "SAL_USE_VCLPLUGIN=gen loffice"
Why use the ugly "gen" plugin, and not "gtk"?
Comment 6 Maxim Monastirsky 2015-09-02 19:44:44 UTC
... and this one is most likely a dup of Bug 93076.

*** This bug has been marked as a duplicate of bug 93076 ***
Comment 7 Maxim Monastirsky 2015-09-02 20:19:50 UTC
(In reply to Maxim Monastirsky from comment #5)
> Looking at the screenshot at suse bugzilla, this is *not* the same bug as
> this one. Instead you should look at Bug 93373.
... In addition, the dialog rendering bug mentioned there is now at Bug 93847. Also Suse bug num. 941051 was wrongly closed as a dup, as it's actually a different problem tracked here at Bug 92412.
Comment 8 Hendrik Woltersdorf 2015-09-10 19:36:10 UTC
(In reply to Maxim Monastirsky from comment #5)
> > "SAL_USE_VCLPLUGIN=gen loffice"
> Why use the ugly "gen" plugin, and not "gtk"?

Until now I only tested "gtk2" and that does not work for me; but "gtk" does. Thanks.

btw: When it not works, I get these messages in the Konsole window, where I started LO5 and opened a Calc sheet:

** (soffice:15260): WARNING **: Invalidate all children called
** (soffice:15260): WARNING **: Unknown event notification 36
Comment 9 Aprax 2016-02-13 12:31:55 UTC
This is still happening in V 5.1.0.3 64 bit in both calc and writer.
see screenshots labeled bug rendering in xxx v 5.1.0.3
Comment 10 Aprax 2016-02-13 12:34:55 UTC
Created attachment 122612 [details]
bad rendering v 5.1.0.3 calc