Download it now!
Bug 93216 - Disabling sidebar / color of the hiding bar
Summary: Disabling sidebar / color of the hiding bar
Status: RESOLVED DUPLICATE of bug 85905
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2015-08-06 21:00 UTC by lupurus
Modified: 2016-10-24 16:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lupurus 2015-08-06 21:00:07 UTC
Two things:

1) I often uses the styles sidebar. The new sidebar you imported from the IBM Lotus Symphony source is - for me - not very useful (it's very confusing and because I'm working with styles, I don't need the formatting options). Eitherway: I activate the styles sidebar with cmd+T (I think it's Ctrl+T in Windows). Pressing cmd+T again only hides the styles panel but leaves a small annoying sidebar with some icons. I don't need them and only disabling the sidebar over the menu completely hides the sidebar. Could you please add the option to disable the sidebar (espacially if I just want to see the styles sidebar)?

2) If the sidebar is activated, there is a small ">" button at the divider. This button is in a very very dark gray. This is also very annoying and there is no option to disable this button or change the color.


I really like LibreOffice, but please make a more minimalistic design so that it's possible to focus at the text / work :)
Comment 1 V Stuart Foote 2015-08-07 02:06:25 UTC
(In reply to lupurus from comment #0)

Regards 1)

The Sidebar was not imported from IBM Symphony. It was implemented by devs on the Apache OpenOffice project as the Sidebar, and then extensively modified to use GTK+ Glade UI layout for LibreOffice releases since 4.1.0

In course of developing Sidebar, the Styles and Formatting dialog was disabled, and Styles are now only available in the Sidebar container. Or minimally from the Formatting toolbar.

You mention cmd+T, so we'll assume that places you on an OS X system? 

F11 is the control used by LibreOffice / AOO / OOo to launch the Styles and Formatting dialog--and now Sidebar.  But the Customize dialog is provided to assign any key to the function.

At present the Sidebar is monolithic, it can be docked or undocked, but there is no way to open the individual content panels in decks of their own. That is bug 85905, going to set this a duplicate of that. 


Regards 2) 

at 5.0.0 the Show/Hide Sidebar button was reworked per bug 83527, in flattening the "grip" the color agreed on in the design process was the "DarkShadowColor" of the active Desktop Environment, while changing to a light blue when selected.

> I really like LibreOffice, but please make a more minimalistic design so
> that it's possible to focus at the text / work :)

Thanks we're pretty focused as it is, but annotated mock-ups of specific issues might be a bit more helpful. Please submit well researched issues to the ux-advise component.

*** This bug has been marked as a duplicate of bug 85905 ***
Comment 2 Yousuf Philips (jay) (retired) 2015-08-09 19:25:20 UTC
Hi lupurus,

I believe your first suggestion is a duplicate of bug 90843. Regarding your second suggestion, the color of the button depends on a user's OS theme, just like libreoffice uses the OS theme, so we can have it a particular color that may not look good on a user's theme.