Bug 93225 - Webdav don't work
Summary: Webdav don't work
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-07 08:16 UTC by francois.creach
Modified: 2016-05-12 12:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The wireshark report (10.82 KB, application/octet-stream)
2015-08-08 18:26 UTC, francois.creach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description francois.creach 2015-08-07 08:16:18 UTC
Hi,

Since the update 5.0.0.5 LOo can no longer connect to webdav.

Regards
Comment 1 Julien Nabet 2015-08-07 22:37:11 UTC
François: could you provide some details? (error message for example)

Giuseppe: thought you might be interested in this one.
Comment 2 Giuseppe Castagno (aka beppec56) 2015-08-08 09:20:37 UTC
François:
you should provide us the operating system you are using and especially the WebDAV server you are using.

Alternatively you can provide a net log while you are connecting to the WebDAV server registered using wireshark:
https://www.wireshark.org/
That would be the better help for us.

But beware that some reserved information can be in the net log.
Comment 3 Julien Nabet 2015-08-08 09:24:26 UTC
Giuseppe: about operating system, it's Windows (see Hardware part of bugtracker)
Comment 4 Giuseppe Castagno (aka beppec56) 2015-08-08 10:03:32 UTC
Julien:
Thanks, sorry I forgot it.

François:
if you can provide the WebDAV type and possibly the wireshark log, thank you.
Comment 5 francois.creach 2015-08-08 18:26:04 UTC
Created attachment 117774 [details]
The wireshark report
Comment 6 francois.creach 2015-08-08 18:26:50 UTC
Hi,

In first, excuse my english !

For me, many things do not work.

The first :
After having checked the box for use libroffice dialogs in the options.
I clic on file > Open > Servers
I complete the elements and after send nothing is happening.

The second :
I double clic in on the server that i just create and in the dialog box my elements and my username no longer appears and the box i have checked is no longer (https).
I complete the elements and after send nothing is happening.

The third : 
I use another method , edit online since my electronic document management ( Alfresco ) . It's fine work with 4x.x release and not with this release.

In all three cases there is no error message.

Thank you for your help and your work.
François
Comment 7 Giuseppe Castagno (aka beppec56) 2015-08-10 08:25:52 UTC
François:

thank you for the wireshark log.

Unfortunately being the  protocol scheme https, I could only see that there is an exchange between a https server and your PC.

Unfortunately it's not sufficient to figure out what's happening.

Now, when you find some spare time, I'd like you to try connecting the WebDAV server directly, using the absolute Internet path:

- close and restart LO, keep the LO dialogs selected in the options.

- then, in the file open text box fill in the full path to the directory containing the file you want to open, like this:

https://server_name-or-ip_address/directory

hit the open button, LO should ask you for the the credentials and
the webdav folder should open.

This will by-pass the Server dialog stuff.

Thank you.
Comment 8 francois.creach 2015-08-10 11:49:06 UTC
Ok it's works with http(s) protocol in Loo !
Thank you

But the problem is that Libreoffice don't recognize the webdav(s) protocol when i clic on a link into the browser (in https or in davs).
In firefox, the association of ldap and Loo 4.x works but note with Loo 5.x.
No error message appear.
Comment 9 Giuseppe Castagno (aka beppec56) 2015-08-10 13:57:22 UTC
(In reply to francois.creach from comment #8)

...

> 
> But the problem is that Libreoffice don't recognize the webdav(s) protocol
> when i clic on a link into the browser (in https or in davs).
> In firefox, the association of ldap and Loo 4.x works but note with Loo 5.x.
> No error message appear.

François, when you have spare time, could you please add another issue, describing this behavior? And please add me in the cc list.

Julien:

this issue to me appears more on the GUI side then ucb/webdav.
Probably the description should be adjusted to that, and this notified to a a dev working on that area?

Tnx.
Comment 10 Julien Nabet 2015-08-10 14:16:34 UTC
ux-team: any thought about this bugtracker?
Indeed, if something must be changed in GUI, you may have some opinion/ideas about this.
Comment 11 francois.creach 2015-08-10 15:02:22 UTC
Ok i open another issue.
Regards
Comment 12 francois.creach 2015-08-12 09:54:34 UTC
I have open a new issue : 93327 (https://bugs.documentfoundation.org/show_bug.cgi?id=93327)
But for the moment no news...
Comment 13 Yousuf Philips (jay) (retired) 2015-08-14 18:26:35 UTC
Dont fully comprehend what is being said here.
Comment 14 Giuseppe Castagno (aka beppec56) 2015-12-30 17:00:40 UTC
(In reply to Yousuf (Jay) Philips from comment #13)
> Dont fully comprehend what is being said here.

From comment 6 I though that the user had problem with UI, going deeper resulted the bug reporter had a specific problem about some WebDAV dedicated protocols no longer works.

Summing up:
- bug 93327 tracks bug reporter 'real' problem;
- bug 96833 tracks a similar UI problem in 5.2 codeline, your thoughts on that one will be appreciated;
- the UI part of this bug may or may not be solved by backporting code from bug 96833 I am working on, but I don't know the 5.0 codeline on that area, yet.
Comment 15 francois.creach 2016-01-18 16:24:36 UTC
Hi,

The problem is the same with the version > 4.2.8.

Thanks
Comment 16 Giuseppe Castagno (aka beppec56) 2016-03-16 09:14:51 UTC
(In reply to francois.creach from comment #15)

> 
> The problem is the same with the version > 4.2.8.
> 
> Thanks

François:

the update to the alfresco addon available here:
<https://github.com/CesarCapillas/alfresco-share-online-edition-addon/releases/tag/0.3>


should have solved your problem.

Did you find time to try it?
Comment 17 francois.creach 2016-05-12 12:29:18 UTC
Hi,

We have test the evolution of the addon.
It's works !
Thanks !