Bug 93233 - clock face emoji autocorrect collisions in some languages
Summary: clock face emoji autocorrect collisions in some languages
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.4 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.2
Keywords:
: 93143 93465 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-08-07 11:25 UTC by baffclan
Modified: 2016-10-25 19:23 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description baffclan 2015-08-07 11:25:48 UTC
cannot used clock face emoji
1:30, 2:30, 3:30, 4:30, 5:30, 6:30, 
7:30, 8:30, 9:30, 10:30, 11:30, 12:30

Steps to Reproduce:
(e.g, clock face five-thirty (U+1F560))
1. type ":5:30:"

Actual Results:
🕔30:

Expected Results:
🕠
Comment 1 tommy27 2015-08-10 18:39:05 UTC
in the :5:30: pattern there's a clear collision with the :5: pattern which is reserved for 5 o'clock

that why you get a 5 o'clock emoji followed by 30:

you have to use different patterns not using the middle :

something like :5.30: should work and not collide with :5:

as far as I see in some languages like Hungarian it was achieved this way but I see other languages (i.e. Dutch) where the collision patterns are present.

so we should check all the default autocorrect list to unify them to a :X.30: pattern
Comment 2 tommy27 2015-08-12 07:28:50 UTC
*** Bug 93143 has been marked as a duplicate of this bug. ***
Comment 3 tommy27 2015-08-12 07:30:43 UTC
(In reply to tommy27 from comment #1)
> 
> ...
> 
> as far as I see in some languages like Hungarian it was achieved this way
> but I see other languages (i.e. Dutch) where the collision patterns are
> present.
> 
> so we should check all the default autocorrect list to unify them to a
> :X.30: pattern

collision :X:30: pattern present in the italian autocorrect list as well.

@Valter Mura
would you please fix it for 5.0.1 release?
Comment 4 Valter Mura 2015-08-13 22:10:21 UTC
will check and ask to developers :)
Comment 5 Valter Mura 2015-08-13 22:12:38 UTC
Christian, Sophie, is it possible to work on it?

BRDGS,

Valter
Comment 6 Christian Lohmaier 2015-08-14 11:44:18 UTC
well - only thing I can do is try to educate translators about it.. But also affects  english
Comment 7 tommy27 2015-08-14 15:58:37 UTC
it seems that only Hungarian uses the right :X.30: pattern
Comment 8 Valter Mura 2015-08-15 08:59:01 UTC
Christian, as per your last email in l10n list, I suppose this bug should be automatically solved from master, isn't it?
Comment 9 Christian Lohmaier 2015-08-15 10:09:20 UTC
no - no automatic fix for translations. Translators need to fix the strings themselves.

What will be done automatically is the copying of the translations of the current English string (e.g 5:50) to the corrected one (e.g. 0530). Translators won't have to retranslate/the strings won't be flagged as unknown.

But no change in master was done yet, this is still to be done. In any case translators have to fix the strings when they are using using ":" as part of an emoji entry.
Comment 10 tommy27 2015-08-15 13:02:16 UTC
I think it would be better to decide which is the correct pattern to use and apply the same pattern to all languages...

:X:30: is not good

:X.30: works and is already used in the Hungarian list

:X30: would be good too 

but I think it would be better not to see some languages using :X.30: and other :X30:

considering that numbers do not need translation I also think it could be a clever idea to move all those clock faces emojis to the [All] autocorrect database (acor_und.dat) so we have a sigle list to edit instead of editing the same entries in any language LibO supports...
Comment 11 Adolfo Jayme 2015-08-16 15:37:57 UTC
*** Bug 93465 has been marked as a duplicate of this bug. ***
Comment 12 Valter Mura 2015-08-17 10:00:04 UTC
Corrected for Italian X:30 > X.30

But I noticed Spanish, French and Catalan have same pattern as Italian, so maybe they could experience the same problems... adding them to the thread :)
Comment 13 tommy27 2015-08-17 13:19:22 UTC
probably all languages except hungarian use the wrong :X:30: pattern
Comment 14 jmontane 2015-08-17 16:45:11 UTC
Corrected for Catalan, X:30 > X.30 is the used workaround
Comment 15 Adolfo Jayme 2015-08-18 07:16:02 UTC
Applied the same workaround to the Spanish translation =)
Comment 16 baffclan 2015-08-18 10:04:03 UTC
I think, It is not a translation problem.
English words(msgid) are not good.
Comment 17 tommy27 2015-08-31 19:21:34 UTC
(In reply to baffclan from comment #16)
> I think, It is not a translation problem.
> English words(msgid) are not good.

I think you refer to Bug 93233
Comment 18 Commit Notification 2015-09-02 12:36:26 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b14680fbdde35ed60a2bde21fcfc839cb7c1ffd3

tdf#93233 fix clockface emoji entries

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2015-09-02 12:37:43 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d3693250e4d436fc553f58a86d171e67ef1bc5c6&h=libreoffice-5-0

tdf#93233 fix clockface emoji entries

It will be available in 5.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Adolfo Jayme 2015-09-07 20:37:45 UTC
Cloph has also updated Pootle, so it should be fine now. Thanks!