Download it now!
Bug 93242 - Ruler numbers have 14 decimal places after upgrade
Summary: Ruler numbers have 14 decimal places after upgrade
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 101469 (view as bug list)
Depends on:
Blocks: Rulers
  Show dependency treegraph
 
Reported: 2015-08-07 14:06 UTC by Ian Chard
Modified: 2018-06-20 02:49 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of Writer with ruler problem (127.33 KB, image/png)
2015-08-07 14:06 UTC, Ian Chard
Details
Screenshot of Writer rulers on 4k display Win 10 v5.2.0.4 (32.78 KB, image/png)
2016-09-18 10:33 UTC, Mably
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Chard 2015-08-07 14:06:47 UTC
Created attachment 117749 [details]
Screenshot of Writer with ruler problem

I just upgraded to 5.0.0.5 on Windows 8.1, and the some of the numbers on the ruler in Writer have many digits after the decimal places, with others missing:

1   3   4.00000000000001   <gap>  10  11  13  13.00000000000001 (etc)

Please see attached screencap.
Comment 1 tommy27 2015-08-19 18:31:00 UTC
strange...
I do not see that bug under Win8.1 x64 using LibO 5.0.0.4 and a recent 5.1.0.0 alpha

did you try resetting the user profile?
https://wiki.documentfoundation.org/UserProfile
Comment 2 Ian Chard 2015-08-20 10:07:00 UTC
I tried removing the user profile.  It was regenerated when Writer started, but the ruler problem is still there.

In case it matters I'm running at 3840x2160.
Comment 3 tommy27 2015-08-20 12:45:44 UTC
that hi-res setting may be a clue.
did you try lower monitor resolution to see if the bug persists?
which is your graphic card? did it worked fine in previous LibO releases on the same system?
Comment 4 Buovjaga 2015-09-10 13:49:49 UTC
Does it only occur when the window is maximized?
Do you have HiDPI scaling turned on in Windows?
Comment 5 m.a.riosv 2016-08-13 12:25:25 UTC
*** Bug 101469 has been marked as a duplicate of this bug. ***
Comment 6 Mably 2016-09-17 23:58:21 UTC
I can confirm the ruler display bug on my Asus laptop with 4K screen.

I can provide a screenshot if needed.
Comment 7 Buovjaga 2016-09-18 08:17:47 UTC
Mably: are you using version 5.2.x? On Windows..?
Screenshot would be nice.
Let's set to NEW.
Comment 8 Mably 2016-09-18 10:33:46 UTC
Created attachment 127404 [details]
Screenshot of Writer rulers on 4k display Win 10 v5.2.0.4
Comment 9 Mably 2016-09-18 11:09:51 UTC
Bug also present in 5.2.1.2.
Comment 10 QA Administrators 2018-06-20 02:49:22 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug