Bug Hunting Session
Bug 93278 - [UI] In Autofilter taborder does not work, neither alt shortcut
Summary: [UI] In Autofilter taborder does not work, neither alt shortcut
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-08-08 15:19 UTC by Emersson Augusto Suarez Ortiz
Modified: 2016-09-19 20:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emersson Augusto Suarez Ortiz 2015-08-08 15:19:22 UTC
when you open Auto-filter, the buttons at bottom only work with the mouse click, if you use tab to get it and enter to action, it does not work.
Comment 1 Emersson Augusto Suarez Ortiz 2015-08-08 15:29:45 UTC
It only is evident when you use the mouse for other action, but when you use alt+A at the first time after search, it work.
Comment 2 Emersson Augusto Suarez Ortiz 2015-08-10 14:45:03 UTC
In addition, when you use the search box it never get the focus, and it is impossible to get acces when you miss when you're typing. The Tab orden does not work and in Windows it has not Alt Sort cuts.
Comment 3 Emersson Augusto Suarez Ortiz 2015-08-10 15:47:31 UTC
When you use the search box, some times after Enter it apply the filter, some times don't. In Windows, in Linux, never happen.
Comment 4 raal 2015-08-21 06:33:27 UTC
Version: 5.1.0.0.alpha1+
Build ID: 6b7354ae66db40246a09e00aa876443057655a43
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-08-19_01:05:16

TAB key works for me.
ALT+A works forme.
ALT+S (Standard filter] doesn't work
search box never get the focus
Comment 5 Cor Nouws 2015-10-09 12:08:26 UTC
probably caused by the work for bug 89908
Comment 6 Dennis Francis 2015-10-15 15:08:59 UTC
Just tested on LO Version: 4.4.5.2
Build ID: 4.4.5.2-8.fc22
Locale: en_US.utf8
Distro : Fedora 22

This version is before the addition of autofilter-searchbox feature.
In this version I can confirm that Alt + S (Standard filter) shortcut doesn't work.

--------------------------------------------------------------------------

TAB key and Alt + A works as expected in the latest master version  (5.1.0.0.alpha1+) as raal reported.

I also can confirm that "auto filter search box" does not receive focus on clicking on it in the latest master branch version.
Comment 7 Xisco Faulí 2016-09-12 12:17:33 UTC
Adding keyword 'bibisectRequest'.
Comment 8 Cor Nouws 2016-09-19 20:19:55 UTC
already much better than it ever was!
Search box gets the focus (even twice on tabbing) 
Other elements get focus too
Search by typing works in the list
Accelerators on OK, All, Cancel

Only the Sort items and Top 10 (non) Empty only work with a mouse
Comment 9 Cor Nouws 2016-09-19 20:22:37 UTC
close as resolved, fixed, open bug https://bugs.documentfoundation.org/show_bug.cgi?id=102298 for the remaining issue