Bug Hunting Session
Bug 93290 - SIDEBAR: Style drop down menu increasing the minimum size of the sidebar
Summary: SIDEBAR: Style drop down menu increasing the minimum size of the sidebar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: Other All
: medium normal
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:5.1.0 target:5.0.2 target:5.0.1
Keywords:
: 93201 (view as bug list)
Depends on:
Blocks: Sidebar-Properties-Style
  Show dependency treegraph
 
Reported: 2015-08-09 01:42 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-09-26 21:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-08-09 01:42:21 UTC
Steps:
1) Open writer
2) Shrink sidebar to minimum size while in properties tab
3) Switch to styles tab and select Bibliography Heading under Heading
4) Switch back to properties tab
5) Attempt to resize sidebar
6) Its minimum size is now double what it used to be

Version: 5.1.0.0.alpha1+
Build ID: 25534a62b2ba398c6298c6b9e521f20de1087540
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-08-07_14:13:33
Locale: en-US (en_US.UTF-8)
Comment 1 Commit Notification 2015-08-09 08:38:09 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7d3fa6bae9f7a755eb2d0ca24bf1afd5f3646bb7

tdf#93290 Limit the size request of the styles combobox

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Maxim Monastirsky 2015-08-09 08:41:09 UTC
Please test it thoroughly. In particular, make sure it doesn't reintroduce Bug 76825.
Comment 3 Yousuf Philips (jay) (retired) 2015-08-10 20:24:37 UTC
Thoroughly tested and no problems in the sidebar or related to bug 76825. Would be good to backport into 5.0 as well.
Comment 4 Maxim Monastirsky 2015-08-10 22:54:20 UTC
Thanks Jay.
Comment 5 Maxim Monastirsky 2015-08-11 18:54:10 UTC
*** Bug 93201 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2015-08-12 12:55:07 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0bc62128589110686bd97b639bae93d29a8bdd8b&h=libreoffice-5-0

tdf#93290 Limit the size request of the styles combobox

It will be available in 5.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Yousuf Philips (jay) (retired) 2015-08-14 12:05:40 UTC
Would be useful to push this into 5.0.1 if its is possible.
Comment 8 Commit Notification 2015-08-17 12:30:41 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d82a0dc64c367a512e33ce1bf498e6e6ebe75bc4&h=libreoffice-5-0-1

tdf#93290 Limit the size request of the styles combobox

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.