Bug 93366 - FILESAVE: Table jumps to the next page when saving DOC file
Summary: FILESAVE: Table jumps to the next page when saving DOC file
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:doc, filter:docx, regression
Depends on:
Blocks: DOC-Tables
  Show dependency treegraph
 
Reported: 2015-08-11 17:52 UTC by Angel
Modified: 2018-07-13 11:34 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Original table with no borders (494.00 KB, application/msword)
2015-08-11 17:52 UTC, Angel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Angel 2015-08-11 17:52:11 UTC
Created attachment 117840 [details]
Original table with no borders

SO: W7, 
LO 5.0.0.5, 
Writer 
.DOC files

When you save a file with a table borders are added to the table. When you reopen the file find the tables with internal borders.

This behavior is new. It didn´t happen with the previous version

Please find attached a file. To reproduce the problem 

1) Open the file
2) Check the tables in page 2. It have no interior borders in the cells
2) Do any minor change
3) Save it
4) Close the file
5) Open the file again
6) Recheck the tables. Now they have borders in the cells


Thank you and best regards

Angel
Comment 1 sophie 2015-08-25 12:14:38 UTC
Hi, I was not able to reproduce with your documents: I remove the borders from the table a save the document, when reopening, there was no borders. With my own document, create a table with no borders, save it to .doc, when reopening, there is no borders to the table. Tested under Ubuntu 15.04, version 5.0.0.5. Left as unconfirmed - Sophie
Comment 2 Buovjaga 2015-09-12 15:24:34 UTC Comment hidden (obsolete)
Comment 3 raal 2015-10-29 08:07:20 UTC
Hello,
I doesn't see problems with the borders, but I can reproduce problem with the table jumps to the 3rd page in version  4.5.0.0.alpha0+ and 5.1Master. I cannot reproduce problem with table jump in version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89) -> regression.

Please could you attach printscreen of borders? Thank you.
Comment 4 Buovjaga 2015-10-29 10:55:36 UTC
Hm, now I can only repro the jumping to 3rd page. Adjusting summary.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+
Build ID: fcc2415ade6ae93710bbbda9f7e163045e323105
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-21_16:55:13
Locale: fi-FI (fi_FI)
Comment 5 Angel 2015-10-29 12:11:47 UTC
Thank you for your help.

Borers problems, present in LO version 5.0.0 and 5.0.1, is not present anymore in LO version 5.0.2.

Angel
Comment 6 raal 2015-12-02 17:55:19 UTC Comment hidden (obsolete)
Comment 7 raal 2016-01-01 16:27:26 UTC
reproducible with Version: 4.2.0.0.alpha1+
Build ID: fc8f44e82de4ebdd50ac5fbb9207cd1a59a927e3
Comment 8 Xisco Faulí 2016-09-12 12:48:40 UTC Comment hidden (obsolete)
Comment 9 Xisco Faulí 2016-10-05 22:46:51 UTC
Regression introduced by

author	Pierre-Eric Pelloux-Prayer <pierre-eric@lanedo.com>	2013-01-10 17:45:42 (GMT)
committer	Noel Power <noel.power@suse.com>	2013-01-14 15:35:13 (GMT)
commit	ee9f23bb94b4c2c8c4db6466ecca272a092e9492 (patch)
tree	1b851fa95c516d9a30d9d489a4dae3371c0ea11c
parent	e85b4e8531125c5b437db515981a344138b8fdd5 (diff)

docx export: invalid sectPr added at the beginning of the doc

This reverts commit 60fa5057039d2413d56813df4d45e5cfdfbb40ac,
which was a revert of 723f772d (fix for ooo#106749) with an
alternative fix to avoid a regression (fdo#56513).

This commit contain a fix for the sectPr issue, and does not
regress on the 2 previously fixed issue.

Adding Cc: to Pierre-Eric Pelloux-Prayer
Comment 10 Xisco Faulí 2018-07-13 11:04:45 UTC Comment hidden (obsolete)
Comment 11 Xisco Faulí 2018-07-13 11:34:10 UTC
This issue is fixed in master and LibreOffice 6.1 RC1 by https://cgit.freedesktop.org/libreoffice/core/commit/?id=7e92a996d1588bdf2ff1e2df10220a0f57686cfb