Bug 93427 - AltGr key acts like "Select All" in Find & Replace diaglog
Summary: AltGr key acts like "Select All" in Find & Replace diaglog
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2015-08-14 14:22 UTC by Antanas
Modified: 2017-05-02 12:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antanas 2015-08-14 14:22:25 UTC
This bug I noticed only in one application – LibreOffice, therefore I'm writing here. In paralell I'm suspecting Unity/Ubuntu fault (and filled a bug report in bugs.launchpad.net). During three days there is no catch. 

Description:
While inserting a symbol from the third keyboard level using combinations with AltGr (right Alt) in Search/Replace fields all previously entered symbols are deleted (BTW I'm using Lithuanian standard layout, but switching to other layouts makes no difference).

Reproduction steps:
Open desired LibreOffice document,
hit Ctrl+F or Ctrl+H ("Search" or "Search and Replace"),
Type some chars,
Press AltGr (right Alt) key.

Result:
the text in the field is selected. Entering next char removes all previously entered characters.

Sometimes the bug appears not right after user login but 1 or few minutes later.

System setup:
LibreOffice – tested with several versions (including latest fresh).
Unity 7.2.5
Ubuntu 14.04.3 LTS 32 bit

In nearest environment several PCs suffer from this bug. 
Only one PC with similar setup doesn't have the bug. The only software difference it have – Ubuntu OS is 64-bit.
Comment 1 Cor Nouws 2015-08-14 15:25:32 UTC
Hi Antanas,

Thanks for your report here!

I did the steps in 4.4.5 on Ubuntu 32 bits and do not have the problem.. SO sorry, I can't confirm
Comment 2 Buovjaga 2015-09-12 16:16:36 UTC
Which LibO version are you using?

Could not repro on Win 7 & Linux, LibO 5.0.1.
Comment 3 Xisco Faulí 2016-09-11 13:53:53 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2017-05-02 11:36:46 UTC Comment hidden (obsolete)
Comment 5 Antanas 2017-05-02 12:48:34 UTC
I moved to another town and have no more access to those machines, which suffered from this bug. Afterwards I didn't noticed this on machines I'm working on (maybe because I don't use Canonical's Unity anymore).
Comment 6 Cor Nouws 2017-05-02 12:59:46 UTC
Thanks Antanas for your report. Lets resolve as WorksForMe than.