Bug 93483 - UI: Context menu listing of Sheets not navigable when extended beyond screen height
Summary: UI: Context menu listing of Sheets not navigable when extended beyond screen ...
Status: RESOLVED DUPLICATE of bug 92702
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.1.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sheet-Tabs-Bar
  Show dependency treegraph
 
Reported: 2015-08-17 11:13 UTC by Jaise James
Modified: 2017-10-14 08:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
selection not possible below overflow arrow (110.13 KB, image/jpeg)
2015-08-17 11:13 UTC, Jaise James
Details
selection not possible below overflow arrow (211.83 KB, image/jpeg)
2015-08-17 11:14 UTC, Jaise James
Details
Sample file attached (8.53 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-08-17 11:19 UTC, Jaise James
Details
sheet selection possible (88.68 KB, image/jpeg)
2015-08-18 05:15 UTC, Jaise James
Details
sheet selection not possible (86.89 KB, image/jpeg)
2015-08-18 05:17 UTC, Jaise James
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaise James 2015-08-17 11:13:41 UTC
Created attachment 117962 [details]
selection not possible below overflow arrow
Comment 1 Jaise James 2015-08-17 11:14:09 UTC
Created attachment 117963 [details]
selection not possible below overflow arrow
Comment 2 Jaise James 2015-08-17 11:19:44 UTC
Created attachment 117965 [details]
Sample file attached

If we scroll, unable to make a selection on previously overflow hidden area.
Comment 3 tommy27 2015-08-17 13:43:09 UTC
please give a detailed step-by-step description how to reproduce the bug and tell your O/S
Comment 4 Adolfo Jayme Barrientos 2015-08-17 17:36:58 UTC
Well, the reporter’s OS is obviously Windows XP, as seen in the screenshots…
Comment 5 GerardF 2015-08-17 18:50:24 UTC
Step by step:
1 Open the attached file
2 Right-click on the arrow at the left of sheets tabs
3 You will see list of sheets names but not all
(with my screen resolution, the last is 'sheet 63')
4 Scroll with mouse on this list
5 Click on sheet name after the last previous showned (exept the 1st one, in my case after 'sheet 64')

Nothing happens.
Comment 6 Jaise James 2015-08-18 05:15:46 UTC
Created attachment 117986 [details]
sheet selection possible

Please see blue colour selection - mouse over area on screen shot.
Comment 7 Jaise James 2015-08-18 05:17:49 UTC
Created attachment 117987 [details]
sheet selection not possible

please see the sheet 57 with mouse over. but no blue colour & also no selection possible. earlier it was below the overflow scroll indicator.
Comment 8 V Stuart Foote 2015-09-18 18:17:33 UTC
confirming on Windows 8.1 Pro 64-bit en-US with
Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: en-US (en_US)

Better STR:

1. Create a new Calc document
2. Add a dozen of new sheets to the spreadsheet using the "+" button
3. Right mouse "context" menu selection of the "<" or ">" button will show the dozen sheets by name, and any of them can be selected. Calc focus moves to that sheet.
4. Add several more dozens of sheets.
5. Context menu will reach a vertical limit of the monitor size, and extends off screen (happens for me with 56 sheets exposed on 1920x1200 monitor).
6. The context menu can be scrolled downward into range of sheets not initially shown.
7. Mouse click selection of any of these "off screen" sheets from context menu has no effect, and sheet with focus remains where it had been.

@Tomaž, one you might be interested in if you revisit bug 93318
Comment 9 Maxim Monastirsky 2015-09-21 18:33:26 UTC

*** This bug has been marked as a duplicate of bug 92702 ***