Bug Hunting Session
Bug 93491 - Crash of Libreoffice by use of the mediaplayer
Summary: Crash of Libreoffice by use of the mediaplayer
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: x86-64 (AMD64) All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace, regression
: 93490 97692 (view as bug list)
Depends on:
Blocks: Media-Player-Dialog
  Show dependency treegraph
 
Reported: 2015-08-17 19:41 UTC by Wim Heyvaert
Modified: 2017-09-24 03:58 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace (19.39 KB, text/plain)
2015-11-21 02:29 UTC, sawakaze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wim Heyvaert 2015-08-17 19:41:37 UTC
After installing Libreoffice 5.0.0.5 on Windows 10 (on both systems 32bit and 64bit) I had some cashes and i suspect the mediaplayer.
To reproduce these crashes:
Open the gallery. Choose the folder of sounds and dubble click on a sound. On Win10 64bit Libreoffice crashes immediately. On a win10 32bir system libreoffice crashes by closing the madiaplayer.
Comment 1 Julien Nabet 2015-08-17 20:43:49 UTC
*** Bug 93490 has been marked as a duplicate of this bug. ***
Comment 2 sophie 2015-08-19 14:13:13 UTC
Hi, I can confirm the crash using Ubuntu 15.04 when closing the media player, LibreOffice freeze in a first time and after some seconds, crashes. Marked as New - Sophie
Comment 3 sophie 2015-08-19 14:13:54 UTC
Changing OS to all - Sophie
Comment 4 Matthew Francis 2015-08-20 10:16:21 UTC

*** This bug has been marked as a duplicate of bug 93188 ***
Comment 5 Wim Heyvaert 2015-10-07 09:21:57 UTC
I have reopened this bug because this bug is not a duplicate of bug 93188.
After installing version 5.0.2.2  (x64), the crashes still remain. Problem is not solved.
Michael Meeks asked me to attach a stack-trace. I have installed SDK for Windows 10. In the program WinDbg I had to connect it with the process soffice.bin, but this failed.
Comment 6 Buovjaga 2015-10-09 18:54:34 UTC
Bug does not meet the criteria for Status 'REOPENED'
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/REOPENED#Criteria
Status -> UNCONFIRMED
Comment 7 raal 2015-10-10 08:22:51 UTC
No crash with Version: 5.1.0.0.alpha1+
Build ID: 8273350ff48f198efc9dc9c5de5519b8cbdc0cb3
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-10-07_05:54:26
Comment 8 Wim Heyvaert 2015-10-10 09:58:26 UTC
(In reply to raal from comment #7)
> No crash with Version: 5.1.0.0.alpha1+
> Build ID: 8273350ff48f198efc9dc9c5de5519b8cbdc0cb3
> TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time:
> 2015-10-07_05:54:26

Before i used LO 4.4.5 32bit on Wondows 8.1 64bit without problems. The crashes started when i installed LO 5.0.0 64bit on Windows 10 64bit system. Now, with LO 5.0.2 64 bit, the crashes remain.
Comment 9 Wim Heyvaert 2015-10-10 10:03:18 UTC
(In reply to Wim Heyvaert from comment #8)
> (In reply to raal from comment #7)
> > No crash with Version: 5.1.0.0.alpha1+
> > Build ID: 8273350ff48f198efc9dc9c5de5519b8cbdc0cb3
> > TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time:
> > 2015-10-07_05:54:26
> 
> Before i used LO 4.4.5 32bit on Wondows 8.1 64bit without problems. The
> crashes started when i installed LO 5.0.0 64bit on Windows 10 64bit system.
> Now, with LO 5.0.2 64 bit, the crashes remain.
I don't have any more the computer with windows 10 32bit, because i have replaced the OS by Lububtu.
Comment 10 raal 2015-10-10 10:27:57 UTC
I can confirm crash Version: 5.1.0.0.alpha1+ (x64)
Build ID: 09fc6fef2d03ca8558dd6f0eec45d61ceb282cb5
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-09-27_22:33:48, win10

and  5.0.2.2 (x64), win10
Comment 11 Wim Heyvaert 2015-11-12 08:06:55 UTC
Bug remains in version: 5.0.3.2 (x64)
Comment 12 sawakaze 2015-11-21 02:29:49 UTC
Created attachment 120693 [details]
Backtrace

I can confirm crush

confirmed version:
5.1.0.0.alpha1+ (x64)
Build ID: 186f365a2c541c51e404b1fa819f35c9152adaf1
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-11-19_23:26:12

OS: Windows10 x64

I set attachement WinDbg(WinDbg_93491.txt)


Regards,
Sawakaze
Comment 13 Wim Heyvaert 2015-12-19 08:23:28 UTC
Bug remains in version: 5.0.4.2 (x64)
Comment 14 raal 2016-02-10 13:39:04 UTC
*** Bug 97692 has been marked as a duplicate of this bug. ***
Comment 15 Mateusz 2016-02-10 14:33:08 UTC
Im can confirm that bug because im have trouble with use video and music in Libroffice on Windows 10
Comment 16 Buovjaga 2016-02-10 14:38:16 UTC
(In reply to Mateusz from comment #15)
> Im can confirm that bug because im have trouble with use video and music in
> Libroffice on Windows 10

So why change it to unconfirmed, then?
Reverted change.
Comment 17 Mateusz 2016-02-10 14:47:28 UTC
(In reply to Beluga from comment #16)
> (In reply to Mateusz from comment #15)
> > Im can confirm that bug because im have trouble with use video and music in
> > Libroffice on Windows 10
> 
> So why change it to unconfirmed, then?
> Reverted change.

Sorry im clicked accidently
Comment 18 Wim Heyvaert 2016-02-12 08:45:52 UTC
I have installed version 5.1.0.3  (x64) on my Win10 system. The bug is partially solved. When I try to reproduce this bug as I first supposed (open a sound in the gallery) then de media player doesn't crash, but when I try to open a Power Point presentation with an embedded sound, then Libre Office crashes still.
Comment 19 Wim Heyvaert 2016-02-16 16:19:47 UTC
Strange.... After a second attempt to open a Power Point presentation with embedded sound, LibreOffice doesn't crash any more. So I have set the state to "fixed" . But I keep a little reservation.
Comment 20 Buovjaga 2016-02-16 16:37:11 UTC
Well, let's set to WFM.
If it still happens, set back to NEW. We did have other people confirming, so they could re-test as well.