Bug Hunting Session
Bug 93506 - Crash when selecting chart containing a trend line
Summary: Crash when selecting chart containing a trend line
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-08-18 08:01 UTC by Laurent BP
Modified: 2019-02-07 19:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Console output during crash (8.84 KB, text/plain)
2015-08-18 08:01 UTC, Laurent BP
Details
Test file containing a chart with a trend line (14.03 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-08-18 08:10 UTC, Laurent BP
Details
Screenshot with trend line open. (116.72 KB, image/png)
2015-08-18 20:48 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2015-08-18 08:01:17 UTC
Created attachment 117989 [details]
Console output during crash

Description: crash when you select a chart containing a trend line. The file must have been previously saved (just saved, or opened).

Steps to reproduce:
1. Create a XY chart with a trend line
2. Save
3. Click on chart

Actual behavior:
Crash
Comment 1 Laurent BP 2015-08-18 08:10:00 UTC
Created attachment 117990 [details]
Test file containing a chart with a trend line

Other way to reproduce crash:
1. Open attached file
2. Select chart

Note: no crash if chart does not contain trend line
Comment 2 m.a.riosv 2015-08-18 20:48:38 UTC
Created attachment 118005 [details]
Screenshot with trend line open.

Hi Laurent,
I can't reproduce
Win7x64
Version: 5.1.0.0.alpha1+ Build ID: bc397ac8265186531e4e3de17fc9bcb71fd46f2e
TinderBox: Win-x86@39, Branch:master, Time: 2015-08-14_08:05:07

Perhaps resetting the user profile could help.
Comment 3 m.a.riosv 2015-08-18 22:06:04 UTC
I have found that when I close the file, LibreOffice crash.
Win7x64
Version: 5.1.0.0.alpha1+ Build ID: bc397ac8265186531e4e3de17fc9bcb71fd46f2e
TinderBox: Win-x86@39, Branch:master, Time: 2015-08-14_08:05:07
Version: 5.1.0.0.alpha1+ (x64) Build ID: 181a7b27acf29a2728be5a0eb3696796bc7df3da
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-08-17_23:57:39
Comment 4 m.a.riosv 2015-08-18 22:10:01 UTC
No issue with:
Version: 5.0.2.0.0+ (x64) Build ID: c79c5d8066538001959f18cab81f74bd6dacf4c8
TinderBox: Win-x86_64@62-TDF, Branch:libreoffice-5-0, Time: 2015-08-14_15:14:22
Comment 5 Julien Nabet 2015-08-20 05:39:16 UTC
Not assigned since nobody has taken it.
Comment 6 Laurent BP 2015-08-20 06:58:46 UTC
(In reply to Julien Nabet from comment #5)
> Not assigned since nobody has taken it.

Sorry Julien, I mixed QA contact and Assigned to.
I proposed a commit https://gerrit.libreoffice.org/#/c/17853/ but Caolan already fixed it with http://cgit.freedesktop.org/libreoffice/core/commit/?id=b27417623835b1c82475783979a1fb9656b5155e
Comment 7 Julien Nabet 2015-08-20 07:04:17 UTC
No pb! It's great it's already fixed! :-)
Comment 8 Commit Notification 2019-02-07 19:15:42 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/66850d9efb00407b7930500d0ebc6febdb03fa8c%5E%21

uitest for bug tdf#93506 + Trend line dialog

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.