Bug 93642 - Vertical spacing of content missing in DOCX import
Summary: Vertical spacing of content missing in DOCX import
Status: RESOLVED DUPLICATE of bug 36117
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Limitations
  Show dependency treegraph
 
Reported: 2015-08-25 00:29 UTC by Matthew Holloway
Modified: 2016-12-09 10:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Source document (283.33 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-08-25 00:29 UTC, Matthew Holloway
Details
msword rendering of document (58.74 KB, image/png)
2015-08-25 00:30 UTC, Matthew Holloway
Details
Rendering in LibreOffice 5.0.0.5 (211.01 KB, application/pdf)
2015-08-25 00:30 UTC, Matthew Holloway
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Holloway 2015-08-25 00:29:30 UTC
Created attachment 118151 [details]
Source document

In the attached document the vertical spacing on page 2 has been lost.
Comment 1 Matthew Holloway 2015-08-25 00:30:00 UTC
Created attachment 118152 [details]
msword rendering of document
Comment 2 Matthew Holloway 2015-08-25 00:30:32 UTC
Created attachment 118153 [details]
Rendering in LibreOffice 5.0.0.5
Comment 3 Joel Madero 2015-08-25 03:46:28 UTC
Confirmed:
Ubuntu 15.04 x64
LibreOffice 5.0.0.4


Setting as:
NEW
Normal - can prevent high quality work. This could technically be a minor bug because there is the ability to "reset" the spacing but if someone sends you a document it's very hard to collaborate as objects are not maintained in the correct place;
Medium - default

@Matthew - if possibly it would be great to determine if this is a regression. Our team isn't big enough to test every bug to determine if they are regressions but if it is a regression there are additional things we can do to track down the cause. Older versions can be found here: http://downloadarchive.documentfoundation.org/libreoffice/old/

Note that version is the oldest version confirmed on - so if you confirm it on an older version please update the version field. Thanks!
Comment 4 Matthew Holloway 2015-08-26 04:49:30 UTC
Doesn't appear to be a regression as it occurs in LibreOffice 3.3.0.4 too (I haven't tested older versions)
Comment 5 Matthew Holloway 2015-08-27 01:24:44 UTC
Apparently it's the header that is pushing the content down.

Notes from a tester,

"LibreOffice is ignoring the top margin values (3 cm and 7 cm respectively). "

I don't have Microsoft Office so I haven't been able to confirm this.
Comment 6 Oliver Specht (CIB) 2015-10-05 09:44:13 UTC
The page has vertical alignment 'bottom'. 

<w:vAlign w:val="bottom"/>

LO Writer does not support vertical page alignment.
Duplicate to 36117

*** This bug has been marked as a duplicate of bug 36117 ***
Comment 7 Robinson Tryon (qubit) 2015-12-15 11:51:44 UTC Comment hidden (obsolete)