Bug Hunting Session
Bug 93662 - white-list only the latest GL hardware and drivers
Summary: white-list only the latest GL hardware and drivers
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.0.2
Keywords:
: 93568 (view as bug list)
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2015-08-25 15:42 UTC by Michael Meeks
Modified: 2015-09-03 11:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2015-08-25 15:42:40 UTC
We need to tweak the logic or XML blacklist to ensure that only the very latest OpenGL hardware and drivers are used by default.
Comment 1 Michael Meeks 2015-09-03 05:59:17 UTC
Patch for LibreOffice 5.0 only here:

https://gerrit.libreoffice.org/18289
Comment 2 Michael Meeks 2015-09-03 07:52:29 UTC
*** Bug 93568 has been marked as a duplicate of this bug. ***
Comment 3 Commit Notification 2015-09-03 11:07:19 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1bc91425e43f8bd30e3dcdec4a30771de54c55c8&h=libreoffice-5-0

tdf#93662 - allow GL by default only on recent drivers on recent windows.

It will be available in 5.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.