Bug Hunting Session
Bug 93714 - Bring back [Un]Protect Cell context menu for protecting/unprotecting cells
Summary: Bring back [Un]Protect Cell context menu for protecting/unprotecting cells
Status: RESOLVED DUPLICATE of bug 93837
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-27 14:38 UTC by Charles
Modified: 2015-09-02 14:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Charles 2015-08-27 14:38:37 UTC
I just discovered, when reporting the bug in 5.x that there is no way to Unprotect protected cells in 5.x in Writer Tables, that this feature was intentionally removed from the context menu.

Our users use this feature all the time.

Please bring back the context menu choice for this, even if it changes to 'Table > [Un]Protect Cell(s)
Comment 1 Cor Nouws 2015-08-27 15:32:05 UTC
Thanks,
Since I see no means to unprotect a cell now, I set severity to major.
Cor
Comment 2 Cor Nouws 2015-08-27 17:06:20 UTC
*** Bug 93713 has been marked as a duplicate of this bug. ***
Comment 3 Charles 2015-08-28 11:22:41 UTC
Hi Cor,

These are two different issues...

Bug 93713 that you closed as a duplicate of this one was an actual, genuine BUG.

This bug is just a feature/enhancement request to bring back the context menu choices for protecting/unprotecting cells in Writer Tables, which were apparently intentionally removed for some reason.

I think they should be kept separate, so I re-opened the bug reporting the actual bug.
Comment 4 V Stuart Foote 2015-08-28 23:35:07 UTC
Nope, back to dupe of 93713 -- which is now back over to UX-advise to add an "Unprotect cells" back to the Table menu by default.

Toolbar and context menu were "simplified" by Design/UX-advise agreement.

*** This bug has been marked as a duplicate of bug 93713 ***
Comment 5 Charles 2015-09-02 14:27:39 UTC
This is and never was a duplicate of bug 93713.

This was a feature/enhancement request to undo something that was deliberately removed.

So, I'm duping it to my new feature/enhancement request, bug 93837, to 'Allow customization of the Context Menus'...

*** This bug has been marked as a duplicate of bug 93837 ***