Download it now!
Bug 93869 - FILEOPEN Opening this file takes very long and then puts Writer in an unusable unviewable state
Summary: FILEOPEN Opening this file takes very long and then puts Writer in an unusabl...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks:
 
Reported: 2015-09-02 21:33 UTC by jddcef
Modified: 2017-06-16 11:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample test file that 100% CPUs LO (75.70 KB, application/vnd.oasis.opendocument.text)
2015-09-02 21:33 UTC, jddcef
Details
File with only to images linked (65.49 KB, application/vnd.oasis.opendocument.text)
2015-09-06 23:46 UTC, m.a.riosv
Details
File without links (64.75 KB, application/vnd.oasis.opendocument.text)
2015-09-06 23:49 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jddcef 2015-09-02 21:33:52 UTC
Created attachment 118364 [details]
Sample test file that 100% CPUs LO

Open the file. It basically crashes LO, 100% cpu, non responsive. Slooow to open. Flaky on if it will open. When it's open, graphics artifacts, no text, no pages, just all weird.

I was testing an old Bug 70358 and used the test file from that bug report.  

It's a good test case - it should probably be added as an automated test case for future regression prevention.
Comment 1 m.a.riosv 2015-09-03 00:21:35 UTC
Hi @jddcef, thanks for reporting.

There are a lot linked images not accessible with the link:
https://PED.aneel.gov.br/imagens/pixel.jpg

you can find them with the navigator.

Are you sure the linked site is trustworthy?
Comment 2 jddcef 2015-09-03 07:34:40 UTC
I don't know about those links. But it shouldn't matter to the behaviour of LO. Perhaps take out all the images if you can open the file.  Or go offline to cause quick fail.
Comment 3 m.a.riosv 2015-09-06 23:46:04 UTC
Created attachment 118486 [details]
File with only to images linked

Seems it opens quicker with the new 5.0.2.1

Attached the file with only two images linked Menu/Edit/Links
Comment 4 m.a.riosv 2015-09-06 23:49:55 UTC
Created attachment 118487 [details]
File without links

Open really quick for me without the linked images.
Comment 5 Buovjaga 2015-09-15 17:00:50 UTC
Wasn't very slow to open perhaps because I have 100Mbits downstream.
Total glitchfest with artifacts. CPU fans running a bit higher. No crash.
I would think a Brazilian government site is trustworthy.

Win 7 Pro 64-bit, Version: 5.0.1.2 (32-bit)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: fi-FI (fi_FI)
Comment 6 Robinson Tryon (qubit) 2015-12-09 18:08:13 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-01-03 19:42:51 UTC Comment hidden (obsolete)
Comment 8 Xisco Faulí 2017-06-16 11:46:15 UTC
it opens fast in

Version: 5.5.0.0.alpha0+
Build ID: 36b1e6270bf2fbb333e2a69c4bb5931eba418289
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-05-29_14:06:19
Locale: es-ES (es_ES); Calc: group

Closing as RESOLVED WORKSFORME