Download it now!
Bug 93872 - Make Navigator Navigation Toolbar Dockable
Summary: Make Navigator Navigation Toolbar Dockable
Status: RESOLVED DUPLICATE of bug 89566
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-03 05:07 UTC by Jean-Francois Nifenecker
Modified: 2016-09-20 10:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The Navigator Navigation Toolbar (42.89 KB, image/png)
2015-09-03 05:07 UTC, Jean-Francois Nifenecker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Francois Nifenecker 2015-09-03 05:07:21 UTC
Created attachment 118369 [details]
The Navigator Navigation Toolbar

The "Navigation" toolbar available from the Navigator is not dockable, though it has completely replaced the former "Navigation" bar that was at the bottom of the vertical scrollbar. Also, though it can be displayed and separated from the Navigator (see attachment), it doesn't retain its current state when creating a new document or when starting a new session.

So I'd suggest, for better usability of this important toolbar:
-- make it dockable
-- make it retain its current state (hidden/visible ; docked/undocked)

See also bug 93871 about this toolbar naming.
Comment 1 sophie 2015-09-03 07:12:51 UTC
Hi Jean-François, set to New, added Jay, changed to UI and add 93871 to see also.
Sophie
Comment 2 Yousuf Philips (jay) (retired) 2015-09-03 15:29:35 UTC
I dont think docking is the solution and the solution is to integrate it into the navigator as mentioned in bug 89566.
Comment 3 QA Administrators 2016-09-20 10:29:21 UTC Comment hidden (obsolete)
Comment 4 Heiko Tietze 2016-09-20 10:48:40 UTC
Closing as kind of duplicate to follow Jay's comment 2. There is also a blog post about redesigning the Navigator https://design.blog.documentfoundation.org/2016/07/31/how-the-navigator-may-support-object-handling-in-libreoffice-draw/

*** This bug has been marked as a duplicate of bug 89566 ***