Bug Hunting Session
Bug 93911 - CALC: default Ctrl+F SEARCH find only searches in formula and not values
Summary: CALC: default Ctrl+F SEARCH find only searches in formula and not values
Status: RESOLVED DUPLICATE of bug 102506
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-04 05:49 UTC by Peter
Modified: 2016-09-25 05:38 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2015-09-04 05:49:39 UTC
When using FIND you don't get any search results.
The default behaviour seems to be searching only 'formula' and not 'formula and values' as one would expect.

The only way to bypass this is to use FIND & REPLACE but then you still have to manually change the search options to 'formula and values'.

Tested on ubuntu, win7 & win8 all running libreoffice 5.0
Comment 1 raal 2015-09-04 09:32:51 UTC
I agree, setting as new enhancement
Comment 2 raal 2015-10-01 14:15:18 UTC
*** Bug 94664 has been marked as a duplicate of this bug. ***
Comment 3 V Stuart Foote 2015-10-01 15:56:39 UTC
No, that would not be correct in a Spreadsheet.

The more correct and present default search is "Formulas" -- described as "searches for the characters that you specify in formulas and in fixed (not calculated) values...".

The specialized and less common search would be to search Formulas and Values in "Values" which will return fixed as well as formula calculated values. That specialized and non-optimal use is available as an option on the "Find and Replace" dialog.

IMHO changing long established default would lead to inadvertent data corruption and bad UX.
Comment 4 hardikvaria 2015-10-01 17:45:51 UTC
I have seen the opposite being true. Especially if you are in audit or accounting department where most of the numbers are a result of formulas.

Hence they normally want to able to search for both inputted numerical values and
result of formulas.

If there was an option to change the default would also be helpful instead of always going into the 'Find & Replace' Dialog.

Please note that "other" office suites do searching for both 'formula and values' by default.
Comment 5 Cor Nouws 2015-12-02 15:43:00 UTC
(In reply to V Stuart Foote from comment #3)

> IMHO changing long established default would lead to inadvertent data
> corruption and bad UX.

Indeed. Let's close as NotABug.
Comment 6 Tilman Vogel 2016-07-20 10:29:58 UTC
Anyway, an option to change the default would be extremely helpful, because having to manually change an option every time is really frustrating. It would already help if the dialog at least would keep the previous setting, however it resets to "Formulas" every time, you open it.

Also, that option would also be very helpful in the Ctrl+F search bar. Not only the extended find dialog.
Comment 7 Tilman Vogel 2016-07-20 10:31:45 UTC
(In reply to Tilman Vogel from comment #6)
> Anyway, an option to change the default would be extremely helpful, because
> having to manually change an option every time is really frustrating. It
> would already help if the dialog at least would keep the previous setting,
> however it resets to "Formulas" every time, you open it.
> 
> Also, that option would also be very helpful in the Ctrl+F search bar. Not
> only the extended find dialog.

Sorry, it *does* remember the last setting during a session.
Comment 8 mahfiaz 2016-09-25 05:38:42 UTC

*** This bug has been marked as a duplicate of bug 102506 ***