Download it now!
Bug 93982 - helpauthoring: sections with id="howtoget" are renamed to "SectionN"
Summary: helpauthoring: sections with id="howtoget" are renamed to "SectionN"
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HelpAuthoring-Extension
  Show dependency treegraph
 
Reported: 2015-09-07 08:34 UTC by Jan Holesovsky
Modified: 2018-07-28 11:34 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Holesovsky 2015-09-07 08:34:44 UTC
In

helpcontent2/source/text/shared/optionen/01060500.xhp

the sections with id="howtoget" were renamed "SectionN", where N is a number >2.

This is probably to keep section id's uniqueness inside the file.

But we loose the "To access this command" sections, except the first occurrence.

Manually naming id's as "howtoget" in the xhp file does work and the "To access this command..." sections are displayed.
Comment 1 Yousuf Philips (jay) (retired) 2015-09-13 13:37:23 UTC
I cant reproduce this in 3.1.1 or my modified version of 3.1.0.

Was the section id renamed on open or on save and what steps are needed to reproduce.
Comment 2 Regina Henschel 2015-09-15 21:52:36 UTC
I cannot reproduce either. Jan, can you please give a step by step description to reproduce it?
Comment 3 Jan Holesovsky 2015-09-16 07:50:48 UTC
Actually, Olivier reported this, I've only copy/pasted that from bug 93580 :-)

Olivier - can you please check & provide more info if you still see the issue?  Thank you!
Comment 4 Xisco Faulí 2016-09-11 14:02:42 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2016-10-10 10:54:01 UTC Comment hidden (obsolete)
Comment 6 Yousuf Philips (jay) (retired) 2016-10-10 13:00:25 UTC
Setting back to NEW so Olivier can give his input.
Comment 7 Olivier Hallot 2016-10-10 13:04:03 UTC
To avoid the issue, just do not issue 2 sections with the same name under HelpAuthoring Tool (section id uniqueness)

So, in files where the issue shows, break the contents into different files.

One case that shows up is in the statistics help page of Calc.
Comment 8 Olivier Hallot 2018-07-28 11:34:31 UTC
Helpauthoring extension is deprecated. closing wontfix.