Bug 94010 - UI: touchpad two-finger Horizontal scroll backwards with RTL sheet on linux
Summary: UI: touchpad two-finger Horizontal scroll backwards with RTL sheet on linux
Status: RESOLVED DUPLICATE of bug 93352
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.2.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2015-09-08 07:16 UTC by Binyamin Sagal
Modified: 2017-03-05 16:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Binyamin Sagal 2015-09-08 07:16:16 UTC
I am running libreoffice 5.0 git (having fix from bug #80512) and while the scrollbar works now, when scrolling with the Horizontal Wheel it move in the reverse direction.

(USING kde ui in english with RTL sheet)
Comment 1 Jan-Marek Glogowski 2015-09-10 11:03:43 UTC Comment hidden (obsolete)
Comment 2 Binyamin Sagal 2015-09-10 11:08:09 UTC
I use a laptop with touchpad that scrolls Horizontaly when swiping with 2-fingers Horizontaly (the equvalent of having a Horizontal scroll wheel)
Comment 3 Jan-Marek Glogowski 2015-09-10 11:20:20 UTC
Does it work correctly, if you change the backend via SAL_USE_VCLPLUGIN=gen or SAL_USE_VCLPLUGIN=gtk?

At least I can try to make the behavior consistent, but quite probably that's already encoded in Qt.
Comment 4 Binyamin Sagal 2015-09-10 11:24:41 UTC
I just tested with SAL_USE_VCLPLUGIN=gen or SAL_USE_VCLPLUGIN=gtk and both of them are also affected
Comment 5 Buovjaga 2015-09-10 15:09:51 UTC
On Win 7, Lenovo T520, two-finger scrolling horizontally does not work at all in LTR.

Win 7 Pro 64-bit, Version: 5.0.1.2 (32-bit)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: fi-FI (fi_FI)
Comment 6 Buovjaga 2015-09-11 11:07:23 UTC
(In reply to Beluga from comment #5)
> On Win 7, Lenovo T520, two-finger scrolling horizontally does not work at
> all in LTR.
> 
> Win 7 Pro 64-bit, Version: 5.0.1.2 (32-bit)
> Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
> Locale: fi-FI (fi_FI)

Same result with Linux.

Ubuntu 15.04 64-bit 
Version: 5.0.1.2
Build ID: 00m0(Build:2)
Locale: en-US (en_US.UTF-8)
Comment 7 Binyamin Sagal 2015-09-11 11:47:52 UTC
I think the problem with two-finger scrolling horizontally not working at all on LTR is unrelated as it works fine for me (and i have never had a problem)
Comment 8 Lior Kaplan 2015-09-23 21:18:18 UTC
I can reproduce this with 5.0.1 on Debian GNU/Linux 64bit with GTK interface.

Steps to reproduce:
1. Open a new sheet.
2. Mark sheet as RTL (sheet tab context menu or Format -> Sheet option from the menu).
3. With two fingers on the touchpad, scroll left. Notice the columns or the bar doesn't move.
4. With two fingers on the touchpad, scroll right. Notice the columns and the bar move left (opposite to your fingers).
Comment 9 QA Administrators 2016-11-08 10:41:14 UTC Comment hidden (obsolete)
Comment 10 Binyamin Sagal 2016-11-08 14:02:14 UTC
Still effecting me.

Version: 5.1.6.2.0+
Build ID: Gentoo official package
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: he-IL (he_IL.utf8); Calc: group
Comment 11 Shimon Shore 2017-03-05 16:06:12 UTC

*** This bug has been marked as a duplicate of bug 93352 ***