Bug Hunting Session
Bug 94055 - Sorting rows makes autofilter disappear (EDITING)
Summary: Sorting rows makes autofilter disappear (EDITING)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-09 13:00 UTC by Toby
Modified: 2016-09-29 09:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toby 2015-09-09 13:00:22 UTC
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.157 Safari/537.36
Build Identifier: LibreOffice 4.4.5.2

If I have an autofilter set up, and I sort rows, the autofilter dissapears.

Reproducible: Always

Steps to Reproduce:
1. Open a new calc spreadsheet
2. Enter this data in a 2x3 grid

  A B
1 X Y
2 a b
3 c d

3. select row 1 and choose data/filter/autofilter
4. select rows 2&3 and select data/sort
5. leave the sort as Column A/Ascending, click OK

Actual Results:  
The autofilter dissapears

Expected Results:  
The autofilter should not dissapear

[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 raal 2015-09-09 17:55:38 UTC
Reproducible with Verze: 5.0.1.2
ID sestavení: 81898c9f5c0d43f3473ba111d7b351050be20261, win7

and Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)
Comment 2 QA Administrators 2016-09-20 10:28:53 UTC Comment hidden (obsolete)
Comment 3 Toby 2016-09-29 09:59:59 UTC
v5.2.1.2 win7pro - works for me :) Thank you :)