Download it now!
Bug 94139 - SVG import: wavedrom charts come out wrong
Summary: SVG import: wavedrom charts come out wrong
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.0.1.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:svg
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2015-09-11 17:33 UTC by Dr. David Alan Gilbert
Modified: 2018-12-05 18:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
AN svg generated by wavedrom's example (31.14 KB, image/svg+xml)
2015-09-11 17:33 UTC, Dr. David Alan Gilbert
Details
Screen shot showing inkscapes view of the SVG and libreoffice's (122.36 KB, image/png)
2015-09-11 17:36 UTC, Dr. David Alan Gilbert
Details
example SVG inserted into Draw and correctly rendered (115.03 KB, image/jpeg)
2015-09-11 21:00 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dr. David Alan Gilbert 2015-09-11 17:33:53 UTC
Created attachment 118615 [details]
AN svg generated by wavedrom's example

http://wavedrom.com/editor.html  has a web based editor for creating timing diagrams, it can export as svg.

Those svg's look fine in inkscape and gimp, but are horribly broken on libreoffice (which is a pity because people will probably want to use it to import as diagrams in documents).

(Both with libreoffice 5.0.1.1-1 on fedora and 4.4.5.2-5
Comment 1 Dr. David Alan Gilbert 2015-09-11 17:36:06 UTC
Created attachment 118617 [details]
Screen shot showing inkscapes view of the SVG and libreoffice's
Comment 2 MM 2015-09-11 19:49:23 UTC
Unconfirmed with v4.4.5.2 under windows 7 x64.
Unconfirmed with v5.0.2.1 under mint 17.2 x64.

File is normally shown, doesn't look broken.
Comment 3 V Stuart Foote 2015-09-11 21:00:29 UTC
Created attachment 118622 [details]
example SVG inserted into Draw and correctly rendered

To use an SVG insert it as an image. The SVG import/insert filter works correctly, and renders SVG as well as Gimp or Inkscape. Also if inserted into a Draw document, the SVG can be broken apart for editing if needed. 

Directly opening SVG with Draw does not use the same filter. And that older filter is broken and poorly renders the SVG as shown.

Nothing new here, so probably best closed invalid. Please have a look through the meta bug 88277 if curious. Pretty sure there is a proper duplicate there for opening into Draw that would match this issue.
Comment 4 Dr. David Alan Gilbert 2015-09-14 08:02:54 UTC
Thanks yes, that's fair enough if 88277 covers all of the problems covered by this test file.
Comment 5 Xisco Faulí 2017-09-29 08:53:26 UTC Comment hidden (obsolete)
Comment 6 Roman Kuznetsov 2018-12-05 18:14:38 UTC
(In reply to V Stuart Foote from comment #3)
 
> Directly opening SVG with Draw does not use the same filter. 

now LO 6.2 beta 1 uses SVGio filter and SVG from attach opens in Draw and looks fine

Status->WFM