Download it now!
Bug 94172 - Docked toolbars use “gen” VCL plugin’s gradient instead of KDE theme color
Summary: Docked toolbars use “gen” VCL plugin’s gradient instead of KDE theme color
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0
Keywords:
: 96585 99284 (view as bug list)
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2015-09-12 21:26 UTC by Zeki Bildirici
Modified: 2016-09-24 02:03 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Toolbars with different KDE (131.47 KB, image/jpeg)
2015-09-12 21:26 UTC, Zeki Bildirici
Details
Screenshot of gradient (81.46 KB, image/png)
2016-02-25 10:13 UTC, b149753
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zeki Bildirici 2015-09-12 21:26:33 UTC
Created attachment 118653 [details]
Toolbars with different KDE

Hi,

The docked toolbars seems not applying with KDE color scheme, whereas the new sidebar and floating toolbars apply.

The screenshot can express the issue better. 

Best regards,
Zeki

* Color theme can be changed from - KDE System Settings - Color - Color Scheme.
Comment 1 Buovjaga 2015-09-23 07:20:27 UTC
Reproduced with Breeze dark.

Kubuntu 15.04 64-bit KDE Plasma 5
Version: 5.0.0.5
Build ID: 00m0(Build:5)
Locale: en-US (en_US.UTF-8)
Comment 2 Heiko Tietze 2015-09-30 18:14:11 UTC
+1, Option > Personalization: "Default, no theme" shows a gradient. Setting another (dark) theme is a workaround but there is no perfect fit with the system color.

Arch Linux, KDE, LibO Fresh and Master
Comment 3 andydecleyre 2015-12-18 20:20:43 UTC
*** Bug 96585 has been marked as a duplicate of this bug. ***
Comment 4 andydecleyre 2015-12-18 20:39:02 UTC
Just a heads up for anyone interested in Heiko's workaround, here's my experience:

Tools > Options > Personalization > Own Theme

Type "dark" in the search field and hit return. LibreOffice decides the proper behavior is to close the theme search dialog without making any changes or saving the search term you entered. Hit Select Theme to try again.

Forget search, let's see the suggested themes. Click Color. Wait. Did anything happen? Is anything loading? Click Color again. Wait. There are all these blank boxes, should I click them? Nothing happens if I do.

Forget suggested themes. Type "dark" in the search field and DON'T hit return. Click Search. OK, we get a maximum of 9 dark themes to choose from. I want to avoid pictures, gradients and textures, as I just want a simple color that won't hide items that I need to see. That eliminates 7 of the 9, leaving Dark Carbon and DARK.

Click Dark Carbon and OK. "Due to an unexpected error, LibreOffice crashed." Click OK to relaunch and do the document recovery process if you had any document you care about open. Try again. This time it works, but it's got an ugly color change halfway up the file menu, and the rest is not just dark but black, which I find to look crappy on desktop applications.

Try again, with the DARK theme. More consistent, but all black. And it doesn't seem to affect the bar on the right, whatever it's called, that includes Styles and Formatting.

Anyway, if someone has other dark themes to suggest by name or key word, feel free to comment here.
Comment 5 b149753 2016-02-25 10:13:54 UTC
Created attachment 122980 [details]
Screenshot of gradient
Comment 6 b149753 2016-02-25 10:15:16 UTC
Can confirm this is still an issue.

Running KDE Plasma5 with theme Breeze Dark. Starting up Libreoffice with env var SAL_USE_VCLPLUGIN as kde/gtk doesn't change anything.

Changing the theme isn't particularly user-friendly as andy described, and neither DARK nor carbon look very good.

Is there any way to get a consistent look with LibreOffice and Breeze Dark?
Comment 7 Adolfo Jayme 2016-04-14 15:20:18 UTC
*** Bug 99284 has been marked as a duplicate of this bug. ***
Comment 8 Alexis 2016-05-24 23:49:24 UTC
Bug still present in Arch 4.5.4-1 with libreoffice-fresh 5.1.3-1, plasma-desktop 5.6.4-1 and Breeze Dark
Comment 9 Yousuf Philips (jay) (retired) 2016-09-19 20:36:21 UTC
The issue was also reported by Andreas here.

https://bugs.kde.org/show_bug.cgi?id=369037
Comment 10 Commit Notification 2016-09-22 18:22:29 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=78b944747e374c9245173072cf78e67118344d10

tdf#94172 KDE4 fix gradient toolbars

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Heiko Tietze 2016-09-22 23:20:04 UTC
This issue has been fixed. Thanks a lot!