Bug 94209 - LibreOffice Calc crashes when insert chart
Summary: LibreOffice Calc crashes when insert chart
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.4.5.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: needsWindows10
Keywords:
: 101265 101547 101701 (view as bug list)
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2015-09-14 12:16 UTC by Digo Pratama
Modified: 2017-12-20 14:30 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Digo Pratama 2015-09-14 12:16:02 UTC
Step:
1. Enter normal data not to much.
2. Click Insert > Chart
3. LibreOffice Calc crash
4. LibreOffice start document recovery.

My platform is Windows 1o Pro RTM and my graphic is Intel GMA 3150.
Comment 1 raal 2015-09-14 13:34:18 UTC
I can not confirm with Verze: 5.0.0.5 (x64)
ID sestavení: 1b1a90865e348b492231e1c451437d7a15bb262b, win10

Please test with newer version, http://www.libreoffice.org/download/libreoffice-fresh/
Thank you
Comment 2 Digo Pratama 2015-09-16 01:10:35 UTC
I also tried the same version 5 but also always crashes. Maybe the problem is related to graphics card.
Thanks
Comment 3 Buovjaga 2015-09-19 16:40:41 UTC
Maybe also try this: https://wiki.documentfoundation.org/UserProfile#Resolving_corruption_in_the_user_profile
I don't think it is your gfx card.

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 4 Digo Pratama 2015-09-19 17:49:21 UTC
Thanks.
LibreOffice has now been removed to be replaced AOO but the problem does not arise in the AOO.
Comment 5 Buovjaga 2015-09-20 07:29:09 UTC
Well, fixed is not the correct status.
As inserting a simple chart is so common and no one else is experiencing the crash, it must be something gone wrong in the install or user profile, but as you did not want to test it, I'll set to invalid.
Comment 6 Artem Lebedev 2016-07-12 22:06:31 UTC
I'm experiencing very similar problem. Any time I'm inserting graph or do any manipulations with existing graph in Calc it crashes and starts recovery process immediately.
I tried the trick with the user profile, it did not help.
Comment 7 Buovjaga 2016-07-13 07:49:19 UTC
(In reply to Artem Lebedev from comment #6)
> I'm experiencing very similar problem. Any time I'm inserting graph or do
> any manipulations with existing graph in Calc it crashes and starts recovery
> process immediately.
> I tried the trick with the user profile, it did not help.

What is your version? Your operating system?
Please try to get a backtrace of the crash: https://wiki.documentfoundation.org/QA/BugReport/Debug_Information
Comment 8 jnplg 2016-07-16 05:53:25 UTC
I am getting the problem immediately on any existing or new sheet : 
open calc, you get an empty sheet.
Click on "Chart" and LibreOffice crashes !
Running LO 5.1.4.2 on Windows 10.
Comment 9 Buovjaga 2016-07-16 06:20:53 UTC
(In reply to jnplg from comment #8)
> I am getting the problem immediately on any existing or new sheet : 
> open calc, you get an empty sheet.
> Click on "Chart" and LibreOffice crashes !
> Running LO 5.1.4.2 on Windows 10.

Try this to catch debug information of the crash: https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 10 Buovjaga 2016-07-18 08:59:04 UTC
Crash on inserting chart was reported as fixed in 5.2: bug 100812
Could you test with 5.2: http://www.libreoffice.org/download/pre-releases/

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 11 Larry 2016-08-06 15:53:29 UTC Comment hidden (obsolete)
Comment 12 Larry 2016-08-06 15:55:16 UTC
Calc crashes when I attempt to insert a chart.  If Writer is open, it also crashes.
Previous version 5.0.6 does not crash.
Comment 13 jnplg 2016-08-07 06:35:21 UTC
I upgraded LO from 5.1.4.2 to 5.2.0.4 (on Windows 10).
The problem does no longer appear in this release.
Comment 14 Buovjaga 2016-08-07 09:44:17 UTC
*** Bug 101265 has been marked as a duplicate of this bug. ***
Comment 15 Aron Budea 2016-08-07 15:10:44 UTC
Can anyone who had the crash check this in 5.1.5.2?

I'm also wondering if the reports are about the same crash as the original one, since that occurred in 4.4.5.2, while in Comment 12 Larry says 5.0.6 was fine for him.
Comment 16 Aron Budea 2016-08-16 20:15:14 UTC
*** Bug 101547 has been marked as a duplicate of this bug. ***
Comment 17 Laurent BP 2016-08-22 10:01:32 UTC
I can NOT reproduce on Win 7 with Version: 5.1.4.2 (x64)
Build ID: f99d75f39f1c57ebdd7ffc5f42867c12031db97a
Threads CPU : 4; Version de l'OS :Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR)

May be specific to Win 10 ?
Comment 18 Giacomo 2016-08-22 14:23:29 UTC
Update to  5.2.0.4 solved my issue. Thanks guys.

Microsoft Windows 7 Starter
Version		6.1.7601 Service Pack 1 Compilação 7601
		ASUSTeK COMPUTER INC.
Model		1025C
Type		X86-based PC
Processor	Intel(R) Atom(TM) CPU N2600   @ 1.60GHz, 1600 Mhz, 2 Núcleo(s), 4 Processador(es) Lógico(s)
BIOS V./data	American Megatrends Inc. 1025C.1001, 16/04/2012
SMBIOS v.	2.7
RAM		2,00 GB
Comment 19 Giacomo 2016-08-22 14:24:10 UTC Comment hidden (no-value, obsolete)
Comment 20 Aron Budea 2016-08-24 22:50:38 UTC
*** Bug 101701 has been marked as a duplicate of this bug. ***