Bug 94235 - Ability to add series name to data series label
Summary: Ability to add series name to data series label
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Samuel Mehrbrodt (allotropia)
URL:
Whiteboard: odf target:7.2.0
Keywords:
: 81637 91331 114589 133176 135850 (view as bug list)
Depends on:
Blocks: Chart-Labels
  Show dependency treegraph
 
Reported: 2015-09-15 08:26 UTC by Yousuf Philips (jay) (retired)
Modified: 2021-02-23 13:53 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (112.61 KB, image/png)
2015-09-15 08:26 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-09-15 08:26:17 UTC
Created attachment 118732 [details]
screenshot

Presently its possible to include the category name and value of a data series in its label and it would be useful to be able to add its series name as well. You can see how it is useful in attachment 118730 [details].
Comment 1 Buovjaga 2015-09-19 16:26:47 UTC
OK -> NEW.
Comment 2 Gabor Kelemen (allotropia) 2019-04-16 14:17:52 UTC
*** Bug 114589 has been marked as a duplicate of this bug. ***
Comment 3 Gabor Kelemen (allotropia) 2019-04-16 14:23:25 UTC
*** Bug 91331 has been marked as a duplicate of this bug. ***
Comment 4 Gabor Kelemen (allotropia) 2020-02-06 23:16:12 UTC
*** Bug 81637 has been marked as a duplicate of this bug. ***
Comment 5 Samuel Mehrbrodt (allotropia) 2021-02-03 07:03:18 UTC
*** Bug 133176 has been marked as a duplicate of this bug. ***
Comment 6 Samuel Mehrbrodt (allotropia) 2021-02-03 07:09:33 UTC
Missing ODF 1.3 feature, see bug 133176 for details.
Comment 7 Samuel Mehrbrodt (allotropia) 2021-02-03 07:40:04 UTC
*** Bug 135850 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2021-02-08 06:52:52 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b99f310d3b24dc45e3d84751e810c0bbff1d991b

tdf#94235 Add support for series name in data series labels

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2021-02-08 18:32:46 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/505a8f488965ae236c4bde1cbc70622a5b9d4727

tdf#94235 Only write data-label-series attr to ODF 1.3 docs

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Buovjaga 2021-02-23 13:53:51 UTC
Verified, thanks!

Arch Linux 64-bit
Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: dec32864a61104001cb6ff63c218ea5fb2a7ab1e
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 22 February 2021