Bug 94250 - Quick filter (Data > Filter > Auto Filter) width too small
Summary: Quick filter (Data > Filter > Auto Filter) width too small
Status: RESOLVED DUPLICATE of bug 49813
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-15 20:40 UTC by Jiehong
Modified: 2015-11-08 16:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the defect (203.79 KB, image/png)
2015-09-15 20:40 UTC, Jiehong
Details
Test ODS file (8.44 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-09-15 20:41 UTC, Jiehong
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiehong 2015-09-15 20:40:53 UTC
Created attachment 118753 [details]
Screenshot of the defect

Hello,

Currently, in Calc, when you have a column and you apply quick filter, if any row of this column contains a long string, the window of the quick filter is too short to see it completely.

The quick-filter window should change its width according to the longest string present in the column (horizontal scrolling would not be convenient at all).

I've checked on MS Excel, and the window resizing is the default behaviour.

I've attached a file to show the issue (just click on the quick filter arrow to see it), and a screenshot to quickly see what's wrong.


Tested on version 4.4.5.2 and 5.0.1.2 on Archlinux and Fedora 22.
Comment 1 Jiehong 2015-09-15 20:41:31 UTC
Created attachment 118754 [details]
Test ODS file
Comment 2 Cor Nouws 2015-09-15 21:23:36 UTC
Thanks Jiehong,

I confirm the problem.
Set version (guess it must have been around version 4.3.) and severity/

Cheers - Cor
Comment 3 Cor Nouws 2015-11-05 20:06:58 UTC
*** Bug 95597 has been marked as a duplicate of this bug. ***
Comment 4 Adolfo Jayme 2015-11-08 16:46:42 UTC

*** This bug has been marked as a duplicate of bug 49813 ***